forth.scm 2.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 Nikita <nikita@n0.is>
  3. ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages forth)
  20. #:use-module ((guix licenses) #:prefix license:)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu)
  24. #:use-module (gnu packages m4))
  25. (define-public gforth
  26. (package
  27. (name "gforth")
  28. (version "0.7.3")
  29. (source (origin
  30. (method url-fetch)
  31. (uri (string-append "mirror://gnu/gforth/gforth-"
  32. version ".tar.gz"))
  33. (sha256
  34. (base32
  35. "1c1bahc9ypmca8rv2dijiqbangm1d9av286904yw48ph7ciz4qig"))))
  36. (build-system gnu-build-system)
  37. (arguments
  38. '(#:parallel-build? #f ; XXX: parallel build fails
  39. #:phases
  40. (modify-phases %standard-phases
  41. (add-after 'install 'install-gforth.el
  42. (lambda* (#:key outputs #:allow-other-keys)
  43. (let* ((out (assoc-ref outputs "out"))
  44. (emacs-sitedir (string-append
  45. out "/share/emacs/site-lisp")))
  46. ;; TODO: compile and autoload it.
  47. (install-file "gforth.el" emacs-sitedir)
  48. #t))))))
  49. (native-inputs
  50. `(("m4" ,m4)))
  51. (synopsis "Forth interpreter")
  52. (description
  53. "Gforth is a fast and portable implementation of the ANSI Forth language.
  54. It includes an editing mode for Emacs and an interpreter featuring completion
  55. and history. A generic virtual machine environment, vmgen, is also
  56. included.")
  57. (home-page "https://www.gnu.org/software/gforth/")
  58. (license license:gpl3+)))