123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
- ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
- ;;; Copyright © 2017 David Craven <david@craven.ch>
- ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
- ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
- ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
- ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages firmware)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix utils)
- #:use-module (guix git-download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages)
- #:use-module (gnu packages admin)
- #:use-module (gnu packages assembly)
- #:use-module (gnu packages base)
- #:use-module (gnu packages bison)
- #:use-module (gnu packages cmake)
- #:use-module (gnu packages cross-base)
- #:use-module (gnu packages flex)
- #:use-module (gnu packages gcc)
- #:use-module (gnu packages linux)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages python))
- (define-public ath9k-htc-firmware
- (package
- (name "ath9k-htc-firmware")
- (version "1.4.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/qca/open-ath9k-htc-firmware")
- (commit version)))
- (sha256
- (base32
- "16jbj8avg5jkgvq5lxm0hdxxn4c3zn7fx8b4nxllvr024apk9w23"))
- (file-name (git-file-name name version))
- (patches (search-patches "ath9k-htc-firmware-objcopy.patch"
- "ath9k-htc-firmware-gcc-compat.patch"))))
- (build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'pre-configure
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (chdir "target_firmware")
- ;; 'configure' is a simple script that runs 'cmake' with
- ;; the right flags.
- (substitute* "configure"
- (("^TOOLCHAIN=.*$")
- (string-append "TOOLCHAIN="
- (assoc-ref (or native-inputs inputs) "cross-gcc")
- "\n")))
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (fw-dir (string-append out "/lib/firmware")))
- (for-each (lambda (file)
- (install-file file fw-dir))
- (find-files "." "\\.fw$"))
- #t))))
- #:tests? #f))
- ;; The firmware is cross-compiled using a "bare bones" compiler (no libc.)
- ;; Use our own tool chain for that.
- (native-inputs `(("cross-gcc" ,(cross-gcc
- "xtensa-elf"
- #:xbinutils (cross-binutils "xtensa-elf"
- binutils-2.33)))
- ("cross-binutils" ,(cross-binutils "xtensa-elf" binutils-2.33))
- ("cmake" ,cmake-minimal)
- ("perl" ,perl)))
- (home-page "https://wireless.wiki.kernel.org/en/users/Drivers/ath9k_htc")
- (synopsis "Firmware for the Atheros AR7010 and AR9271 USB 802.11n NICs")
- (description
- "This is the firmware for the Qualcomm Atheros AR7010 and AR9271 USB
- 802.11n NICs (aka Wi-Fi USB dongles). It is used by the ath9k driver of
- Linux-libre.")
- (license (license:non-copyleft "http://directory.fsf.org/wiki/License:ClearBSD"))))
- (define-public b43-tools
- (let ((commit "27892ef741e7f1d08cb939744f8b8f5dac7b04ae")
- (revision "1"))
- (package
- (name "b43-tools")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "http://git.bues.ch/git/b43-tools.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1wgmj4d65izbhprwb5bcwimc2ryv19b9066lqzy4sa5m6wncm9cn"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("flex" ,flex)
- ("bison" ,bison)))
- (arguments
- `(#:modules ((srfi srfi-1)
- (guix build gnu-build-system)
- (guix build utils))
- #:tests? #f ; no tests
- #:phases
- (let ((subdirs '("assembler" "disassembler")))
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- (add-before 'build 'patch-/bin/true
- (lambda _
- (substitute* (find-files "." "Makefile")
- (("/bin/true") ":"))
- #t))
- (replace 'build
- (lambda _
- (for-each (lambda (dir)
- (invoke "make" "-C" dir "CC=gcc"))
- subdirs)
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (mkdir-p (string-append out "/bin"))
- (for-each (lambda (dir)
- (invoke "make" "-C" dir
- (string-append "PREFIX=" out)
- "install"))
- subdirs)
- #t)))))))
- (home-page
- "https://bues.ch/cms/hacking/misc.html#linux_b43_driver_firmware_tools")
- (synopsis "Collection of tools for the b43 wireless driver")
- (description
- "The b43 firmware tools is a collection of firmware extractor,
- assembler, disassembler, and debugging tools for the Linux kernel b43 wireless
- driver.")
- (license license:gpl2))))
- (define-public openfwwf-firmware
- (package
- (name "openfwwf-firmware")
- (version "5.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://netweb.ing.unibs.it/~openfwwf/firmware/"
- "openfwwf-" version ".tar.gz"))
- (sha256
- (base32
- "1p60gdi7w88s7qw82d3g9v7mk887mhvidf4l5q5hh09j10h37q4x"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("b43-tools" ,b43-tools)))
- (arguments
- `(#:make-flags (list (string-append "PREFIX="
- (assoc-ref %outputs "out")
- "/lib/firmware/b43-open"))
- #:tests? #f ;no tests
- #:phases (modify-phases %standard-phases
- (delete 'configure))))
- (home-page "http://netweb.ing.unibs.it/~openfwwf/")
- (synopsis "Firmware for BCM43xx devices")
- (description
- "This is firmware from Open FirmWare for WiFi networks (OpenFWWF) for the
- Broadcom/AirForce chipset BCM43xx with Wireless-Core Revision 5. It is used
- by the b43-open driver of Linux-libre.")
- (license license:gpl2)))
- (define* (make-opensbi-package platform name #:optional (arch "riscv64"))
- (package
- (name name)
- (version "0.8")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/riscv/opensbi")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1y9z0b6q6wpw7mgy31wml4djc6m8ydm71a9f1asnks4ragc7m98b"))))
- (build-system gnu-build-system)
- (native-inputs
- `(,@(if (and (not (string-prefix? "riscv64" (%current-system)))
- (string-prefix? "riscv64" arch))
- `(("cross-gcc" ,(cross-gcc "riscv64-linux-gnu" #:xgcc gcc-7))
- ("cross-binutils" ,(cross-binutils "riscv64-linux-gnu")))
- '())))
- (arguments
- `(#:tests? #f ; no check target
- #:make-flags (list (string-append "PLATFORM=" ,platform)
- ,@(if (and (not (string-prefix? "riscv64"
- (%current-system)))
- (string-prefix? "riscv64" arch))
- `("CROSS_COMPILE=riscv64-linux-gnu-")
- '())
- "FW_PAYLOAD=n"
- "V=1")
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (bin (find-files "." ".*fw_.*.elf$")))
- (for-each
- (lambda (file)
- (install-file file out))
- bin))
- #t)))))
- (home-page "https://github.com/riscv/opensbi")
- (synopsis "RISC-V Open Source Supervisor Binary Interface")
- (description "A reference implementation of the RISC-V SBI specifications
- for platform-specific firmwares executing in M-mode.")
- (license (list license:bsd-2
- ;; lib/utils/libfdt/* is dual licensed under bsd-2 and gpl2+.
- license:gpl2+
- ;; platform/ariane-fpga/* is gpl2.
- license:gpl2))))
- (define-public opensbi-qemu-generic
- (make-opensbi-package "generic" "opensbi-qemu-generic"))
- (define-public opensbi-qemu-virt
- (deprecated-package "opensbi-qemu-virt" opensbi-qemu-generic))
- (define-public opensbi-sifive-fu540
- (make-opensbi-package "sifive/fu540" "opensbi-sifive-fu540"))
- (define-public opensbi-qemu-sifive-u
- ;; Dropped upstream, as all functionality is present in the sifive-fu540
- ;; target for recent versions of qemu, u-boot and linux.
- (deprecated-package "opensbi-qemu-sifive-u" opensbi-sifive-fu540))
- (define-public seabios
- (package
- (name "seabios")
- (version "1.14.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://review.coreboot.org/seabios.git")
- (commit (string-append "rel-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0jp4rxsv9jdzvx4gjvkybj6g1yjg8pkd2wys4sdh6c029npp6y8p"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("python" ,python-wrapper)))
- (arguments
- `(#:tests? #f ; no check target
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda _
- (setenv "CC" "gcc")
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (fmw (string-append out "/share/firmware")))
- (mkdir-p fmw)
- (copy-file "out/bios.bin" (string-append fmw "/bios.bin"))
- #t))))))
- (home-page "https://www.seabios.org/SeaBIOS")
- (synopsis "x86 BIOS implementation")
- (description "SeaBIOS is an implementation of a 16bit x86 BIOS. SeaBIOS
- can run in an emulator or it can run natively on X86 hardware with the use of
- coreboot.")
- ;; Dual licensed.
- (license (list license:gpl3+ license:lgpl3+
- ;; src/fw/acpi-dsdt.dsl is lgpl2
- license:lgpl2.1
- ;; src/fw/lzmadecode.c and src/fw/lzmadecode.h are lgpl3+ and
- ;; cpl with a linking exception.
- license:cpl1.0))))
- ;; OVMF is part of the edk2 source tree.
- (define edk2-commit "13a50a6fe1dcfa6600c38456ee24e0f9ecf51b5f")
- (define edk2-version (git-version "20170116" "1" edk2-commit))
- (define edk2-origin
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tianocore/edk2")
- (commit edk2-commit)))
- (file-name (git-file-name "edk2" edk2-version))
- (sha256
- (base32
- "1gy2332kdqk8bjzpcsripx10896rbvgl0ic7r344kmpiwdgm948b"))))
- (define-public ovmf
- (package
- (name "ovmf")
- (version edk2-version)
- (source edk2-origin)
- (build-system gnu-build-system)
- (native-inputs
- `(("acpica" ,acpica)
- ("gcc@5" ,gcc-5)
- ("nasm" ,nasm)
- ("python-2" ,python-2)
- ("util-linux" ,util-linux "lib")))
- (arguments
- `(#:tests? #f ; No check target.
- #:phases
- (modify-phases %standard-phases
- ;; Hide the default GCC from CPLUS_INCLUDE_PATH to prevent it from
- ;; shadowing the version of GCC provided in native-inputs.
- (add-after 'set-paths 'hide-gcc7
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((gcc (assoc-ref inputs "gcc")))
- (setenv "CPLUS_INCLUDE_PATH"
- (string-join
- (delete (string-append gcc "/include/c++")
- (string-split (getenv "CPLUS_INCLUDE_PATH")
- #\:))
- ":"))
- #t)))
- (replace 'configure
- (lambda _
- (let* ((cwd (getcwd))
- (tools (string-append cwd "/BaseTools"))
- (bin (string-append tools "/BinWrappers/PosixLike")))
- (setenv "WORKSPACE" cwd)
- (setenv "EDK_TOOLS_PATH" tools)
- (setenv "PATH" (string-append (getenv "PATH") ":" bin))
- ; FIXME: The below script errors out. When using 'invoke' instead
- ; of 'system*' this causes the build to fail.
- (system* "bash" "edksetup.sh")
- (substitute* "Conf/target.txt"
- (("^TARGET[ ]*=.*$") "TARGET = RELEASE\n")
- (("^MAX_CONCURRENT_THREAD_NUMBER[ ]*=.*$")
- (format #f "MAX_CONCURRENT_THREAD_NUMBER = ~a~%"
- (number->string (parallel-job-count)))))
- ;; Build build support.
- (setenv "BUILD_CC" "gcc")
- (invoke "make" "-C" tools)
- #t)))
- (replace 'build
- (lambda _
- (invoke "build" "-a" "IA32" "-t" "GCC49"
- "-p" "OvmfPkg/OvmfPkgIa32.dsc")))
- ,@(if (string=? "x86_64-linux" (%current-system))
- '((add-after 'build 'build-x64
- (lambda _
- (invoke "build" "-a" "X64" "-t" "GCC49"
- "-p" "OvmfPkg/OvmfPkgX64.dsc"))))
- '())
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (fmw (string-append out "/share/firmware")))
- (mkdir-p fmw)
- (copy-file "Build/OvmfIa32/RELEASE_GCC49/FV/OVMF.fd"
- (string-append fmw "/ovmf_ia32.bin"))
- ,@(if (string=? "x86_64-linux" (%current-system))
- '((copy-file "Build/OvmfX64/RELEASE_GCC49/FV/OVMF.fd"
- (string-append fmw "/ovmf_x64.bin")))
- '()))
- #t)))))
- (supported-systems '("x86_64-linux" "i686-linux"))
- (home-page "https://www.tianocore.org")
- (synopsis "UEFI firmware for QEMU")
- (description "OVMF is an EDK II based project to enable UEFI support for
- Virtual Machines. OVMF contains a sample UEFI firmware for QEMU and KVM.")
- (license (list license:expat
- license:bsd-2 license:bsd-3 license:bsd-4))))
- (define-public ovmf-aarch64
- (package
- (inherit ovmf)
- (name "ovmf-aarch64")
- (native-inputs
- `(,@(package-native-inputs ovmf)
- ,@(if (not (string-prefix? "aarch64" (%current-system)))
- `(("cross-gcc" ,(cross-gcc "aarch64-linux-gnu"))
- ("cross-binutils" ,(cross-binutils "aarch64-linux-gnu")))
- '())))
- (arguments
- (substitute-keyword-arguments (package-arguments ovmf)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'configure 'set-env
- (lambda _
- ,@(if (not (string-prefix? "aarch64" (%current-system)))
- `((setenv "GCC49_AARCH64_PREFIX" "aarch64-linux-gnu-"))
- '())
- #t))
- (replace 'build
- (lambda _
- (invoke "build" "-a" "AARCH64" "-t" "GCC49"
- "-p" "ArmVirtPkg/ArmVirtQemu.dsc")))
- (delete 'build-x64)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (fmw (string-append out "/share/firmware")))
- (mkdir-p fmw)
- (copy-file "Build/ArmVirtQemu-AARCH64/RELEASE_GCC49/FV/QEMU_EFI.fd"
- (string-append fmw "/ovmf_aarch64.bin"))
- #t)))))))
- (supported-systems %supported-systems)))
- (define-public ovmf-arm
- (package
- (inherit ovmf)
- (name "ovmf-arm")
- (native-inputs
- `(,@(package-native-inputs ovmf)
- ,@(if (not (string-prefix? "armhf" (%current-system)))
- `(("cross-gcc" ,(cross-gcc "arm-linux-gnueabihf"))
- ("cross-binutils" ,(cross-binutils "arm-linux-gnueabihf")))
- '())))
- (arguments
- (substitute-keyword-arguments (package-arguments ovmf)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-before 'configure 'set-env
- (lambda _
- ,@(if (not (string-prefix? "armhf" (%current-system)))
- `((setenv "GCC49_ARM_PREFIX" "arm-linux-gnueabihf-"))
- '())
- #t))
- (replace 'build
- (lambda _
- (invoke "build" "-a" "ARM" "-t" "GCC49"
- "-p" "ArmVirtPkg/ArmVirtQemu.dsc")))
- (delete 'build-x64)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (fmw (string-append out "/share/firmware")))
- (mkdir-p fmw)
- (copy-file "Build/ArmVirtQemu-ARM/RELEASE_GCC49/FV/QEMU_EFI.fd"
- (string-append fmw "/ovmf_arm.bin"))
- #t)))))))
- (supported-systems %supported-systems)))
- (define* (make-arm-trusted-firmware platform #:optional (arch "aarch64"))
- (package
- (name (string-append "arm-trusted-firmware-" platform))
- (version "2.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- ;; There are only GitHub generated release snapshots.
- (url "https://git.trustedfirmware.org/TF-A/trusted-firmware-a.git/")
- (commit (string-append "v" version))))
- (file-name (git-file-name "arm-trusted-firmware" version))
- (sha256
- (base32
- "12k0n79j156bdzqws18kpbli04kn00nh6dy42pjv6gakqrkx9px3"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure) ; no configure script
- ;; Remove binary blobs which do not contain source or proper license.
- (add-after 'unpack 'remove-binary-blobs
- (lambda _
- (for-each (lambda (file)
- (delete-file file))
- (find-files "." ".*\\.bin$"))))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (bin (find-files "." ".*\\.(bin|elf)$")))
- (for-each
- (lambda (file)
- (install-file file out))
- bin))
- #t)))
- #:make-flags (list (string-append "PLAT=" ,platform)
- ,@(if (and (not (string-prefix? "aarch64"
- (%current-system)))
- (string-prefix? "aarch64" arch))
- `("CROSS_COMPILE=aarch64-linux-gnu-")
- '())
- ,@(if (and (not (string-prefix? "armhf"
- (%current-system)))
- (string-prefix? "armhf" arch))
- `("CROSS_COMPILE=arm-linux-gnueabihf-")
- '())
- "DEBUG=1")
- #:tests? #f)) ; no tests
- (native-inputs
- `(,@(if (and (not (string-prefix? "aarch64" (%current-system)))
- (string-prefix? "aarch64" arch))
- ;; Needs newer gcc version for some targets
- `(("cross-gcc" ,(cross-gcc "aarch64-linux-gnu" #:xgcc gcc-9))
- ("cross-binutils" ,(cross-binutils "aarch64-linux-gnu")))
- '())
- ,@(if (and (not (string-prefix? "armhf" (%current-system)))
- (string-prefix? "armhf" arch))
- ;; Needs newer gcc version for some targets
- `(("cross-gcc" ,(cross-gcc "arm-linux-gnueabihf" #:xgcc gcc-9))
- ("cross-binutils" ,(cross-binutils "arm-linux-gnueabihf")))
- '())
- ;; Needs newer gcc version for some targets
- ("gcc" ,gcc-9)))
- (home-page "https://www.trustedfirmware.org/")
- (synopsis "Implementation of \"secure world software\"")
- (description
- "ARM Trusted Firmware provides a reference implementation of secure world
- software for ARMv7A and ARMv8-A, including a Secure Monitor executing at
- @dfn{Exception Level 3} (EL3). It implements various ARM interface standards,
- such as:
- @enumerate
- @item The Power State Coordination Interface (PSCI)
- @item Trusted Board Boot Requirements (TBBR, ARM DEN0006C-1)
- @item SMC Calling Convention
- @item System Control and Management Interface
- @item Software Delegated Exception Interface (SDEI)
- @end enumerate\n")
- (license (list license:bsd-3
- license:bsd-2)))) ; libfdt
- (define-public arm-trusted-firmware-sun50i-a64
- (let ((base (make-arm-trusted-firmware "sun50i_a64")))
- (package
- (inherit base)
- (name "arm-trusted-firmware-sun50i-a64"))))
- (define-public arm-trusted-firmware-rk3328
- (make-arm-trusted-firmware "rk3328"))
- (define-public arm-trusted-firmware-rk3399
- (let ((base (make-arm-trusted-firmware "rk3399")))
- (package
- (inherit base)
- (name "arm-trusted-firmware-rk3399")
- (native-inputs
- `(("cross32-gcc" ,(cross-gcc "arm-none-eabi"))
- ("cross32-binutils", (cross-binutils "arm-none-eabi"))
- ,@(package-native-inputs base))))))
|