123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2016 Steve Sprang <scs@stevesprang.com>
- ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
- ;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
- ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;; Copyright © 2018 Nikita <nikita@n0.is>
- ;;; Copyright © 2021 Oskar Köök <oskar@maatriks.ee>
- ;;; Copyright © 2021 Cees de Groot <cg@evrl.com>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages erlang)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix build-system gnu)
- #:use-module (guix build-system emacs)
- #:use-module (guix download)
- #:use-module (guix git-download)
- #:use-module (guix packages)
- #:use-module (guix utils)
- #:use-module (gnu packages)
- #:use-module (gnu packages fontutils)
- #:use-module (gnu packages gl)
- #:use-module (gnu packages ncurses)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages wxwidgets))
- (define-public erlang
- (package
- (name "erlang")
- (version "24.0.5")
- (source (origin
- (method git-fetch)
- ;; The tarball from http://erlang.org/download contains many
- ;; pre-compiled files, so we use this snapshot of the source
- ;; repository.
- (uri (git-reference
- (url "https://github.com/erlang/otp")
- (commit (string-append "OTP-" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0f8zr2jxr0v4zcd98zqx99zxdn768vjpzwxsbsd6ss3if405sq2a"))
- (patches (search-patches "erlang-man-path.patch"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("perl" ,perl)
- ;; Erlang's documentation is distributed in a separate tarball.
- ("erlang-manpages"
- ,(origin
- (method url-fetch)
- (uri (string-append "http://erlang.org/download/otp_doc_man_"
- (version-major+minor version) ".tar.gz"))
- (sha256
- (base32
- "1c9ccp93pmm54mmvpiyrmj8v00pq11a60c4xv220k97i965zkwsg"))))))
- (inputs
- `(("ncurses" ,ncurses)
- ("openssl" ,openssl)
- ("wxwidgets" ,wxwidgets)))
- (propagated-inputs
- `(("fontconfig" ,fontconfig)
- ("glu" ,glu)
- ("mesa" ,mesa)))
- (arguments
- `(#:test-target "release_tests"
- #:configure-flags
- (list "--disable-saved-compile-time"
- "--enable-dynamic-ssl-lib"
- "--enable-native-libs"
- "--enable-shared-zlib"
- "--enable-smp-support"
- "--enable-threads"
- "--enable-wx"
- (string-append "--with-ssl=" (assoc-ref %build-inputs "openssl")))
- #:modules ((srfi srfi-19) ; make-time, et cetera.
- (guix build utils)
- (guix build gnu-build-system))
- #:phases
- (modify-phases %standard-phases
- (delete 'bootstrap)
- ;; The are several code fragments that embed timestamps into the
- ;; output. Here, we alter those fragments to use the value of
- ;; SOURCE_DATE_EPOCH instead.
- (add-after 'unpack 'remove-timestamps
- (lambda _
- (let ((source-date-epoch
- (time-utc->date
- (make-time time-utc 0 (string->number
- (getenv "SOURCE_DATE_EPOCH"))))))
- (substitute* "lib/reltool/src/reltool_target.erl"
- (("Date = date\\(\\),")
- (string-append "Date = "
- (date->string source-date-epoch
- "'{~Y,~m,~d}',"))))
- (substitute* "lib/reltool/src/reltool_target.erl"
- (("Time = time\\(\\),")
- (string-append "Time = "
- (date->string source-date-epoch
- "'{~H,~M,~S}',"))))
- (substitute* '("lib/reltool/src/reltool_target.erl"
- "lib/sasl/src/systools_make.erl")
- (("date\\(\\), time\\(\\),")
- (date->string source-date-epoch
- "{~Y,~m,~d}, {~H,~M,~S},")))
- (substitute* "lib/dialyzer/test/small_SUITE_data/src/gs_make.erl"
- (("tuple_to_list\\(date\\(\\)\\),tuple_to_list\\(time\\(\\)\\)")
- (date->string
- source-date-epoch
- "tuple_to_list({~Y,~m,~d}), tuple_to_list({~H,~M,~S})")))
- (substitute* "lib/snmp/src/compile/snmpc_mib_to_hrl.erl"
- (("\\{Y,Mo,D\\} = date\\(\\),")
- (date->string source-date-epoch
- "{Y,Mo,D} = {~Y,~m,~d},")))
- (substitute* "lib/snmp/src/compile/snmpc_mib_to_hrl.erl"
- (("\\{H,Mi,S\\} = time\\(\\),")
- (date->string source-date-epoch
- "{H,Mi,S} = {~H,~M,~S},")))
- #t)))
- (add-after 'unpack 'patch-/bin/sh
- (lambda _
- (substitute* "erts/etc/unix/run_erl.c"
- (("sh = \"/bin/sh\";")
- (string-append "sh = \""
- (which "sh")
- "\";")))
- (substitute* "erts/emulator/sys/unix/sys_drivers.c"
- (("SHELL \"/bin/sh\"")
- (string-append "SHELL \""
- (which "sh")
- "\"")))
- (substitute* "erts/emulator/sys/unix/erl_child_setup.c"
- (("SHELL \"/bin/sh\"")
- (string-append "SHELL \""
- (which "sh")
- "\"")))
- (substitute* "lib/kernel/src/os.erl"
- (("/bin/sh") (which "sh")))
- #t))
- (add-after 'patch-source-shebangs 'patch-source-env
- (lambda _
- (let ((escripts
- (append
- (find-files "." "\\.escript")
- (find-files "lib/stdlib/test/escript_SUITE_data/")
- '("erts/lib_src/utils/make_atomics_api"
- "erts/preloaded/src/add_abstract_code"
- "lib/diameter/bin/diameterc"
- "lib/reltool/examples/display_args"
- "lib/reltool/examples/mnesia_core_dump_viewer"
- "lib/snmp/src/compile/snmpc.src"
- "make/verify_runtime_dependencies"
- "make/emd2exml.in"))))
- (substitute* escripts
- (("/usr/bin/env") (which "env")))
- #t)))
- (add-before 'configure 'set-erl-top
- (lambda _
- (setenv "ERL_TOP" (getcwd))
- #t))
- (add-after 'install 'patch-erl
- ;; This only works after install.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out")))
- (substitute* (string-append out "/bin/erl")
- (("sed") (which "sed")))
- #t)))
- (add-after 'install 'install-doc
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (manpages (assoc-ref inputs "erlang-manpages"))
- (share (string-append out "/share/")))
- (mkdir-p share)
- (with-directory-excursion share
- (invoke "tar" "xvf" manpages))
- #t))))))
- (home-page "https://www.erlang.org/")
- (synopsis "The Erlang programming language")
- (description
- "Erlang is a programming language used to build massively
- scalable soft real-time systems with requirements on high
- availability. Some of its uses are in telecoms, banking, e-commerce,
- computer telephony and instant messaging. Erlang's runtime system has
- built-in support for concurrency, distribution and fault tolerance.")
- ;; Erlang is distributed under the Apache License 2.0, but some components
- ;; have other licenses. See 'system/COPYRIGHT' in the source distribution.
- (license (list license:asl2.0 license:bsd-2 license:bsd-3 license:expat
- license:lgpl2.0+ license:tcl/tk license:zlib))))
- (define-public emacs-erlang
- (package
- (name "emacs-erlang")
- (version (package-version erlang))
- (source (package-source erlang))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'expand-load-path 'change-working-directory
- (lambda _ (chdir "lib/tools/emacs") #t)))))
- (home-page "https://www.erlang.org/")
- (synopsis "Erlang major mode for Emacs")
- (description
- "This package provides an Emacs major mode for editing Erlang source
- files.")
- (license license:asl2.0)))
|