ed.scm 2.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
  3. ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
  4. ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages ed)
  21. #:use-module (guix licenses)
  22. #:use-module (guix packages)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages compression))
  26. (define-public ed
  27. (package
  28. (name "ed")
  29. (version "1.17")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append "mirror://gnu/ed/ed-"
  33. version ".tar.lz"))
  34. (sha256
  35. (base32
  36. "0m2yrkfjjraakxr98nsiakqrn351h99n706x9asgmdi57j43kpki"))))
  37. (build-system gnu-build-system)
  38. (native-inputs `(("lzip" ,lzip)))
  39. (arguments
  40. '(#:configure-flags '("CC=gcc")
  41. #:phases
  42. (modify-phases %standard-phases
  43. (add-before 'patch-source-shebangs 'patch-test-suite
  44. (lambda _
  45. (substitute* "testsuite/check.sh"
  46. (("/bin/sh") (which "sh")))
  47. #t)))))
  48. (home-page "https://www.gnu.org/software/ed/")
  49. (synopsis "Line-oriented text editor")
  50. (description
  51. "Ed is a line-oriented text editor: rather than offering an overview of
  52. a document, ed performs editing one line at a time. It can be executed both
  53. interactively and via shell scripts. Its method of command input allows
  54. complex tasks to be performed in an automated way. GNU ed offers several
  55. extensions over the standard utility.")
  56. (license gpl3+)))