easyrpg.scm 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
  3. ;;; Copyright © 2019–2021 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages easyrpg)
  21. #:use-module (guix packages)
  22. #:use-module ((guix licenses) #:prefix license:)
  23. #:use-module (guix download)
  24. #:use-module (guix build-system gnu)
  25. #:use-module (gnu packages audio)
  26. #:use-module (gnu packages compression)
  27. #:use-module (gnu packages fontutils)
  28. #:use-module (gnu packages gtk)
  29. #:use-module (gnu packages icu4c)
  30. #:use-module (gnu packages image)
  31. #:use-module (gnu packages mp3)
  32. #:use-module (gnu packages pkg-config)
  33. #:use-module (gnu packages pulseaudio)
  34. #:use-module (gnu packages sdl)
  35. #:use-module (gnu packages xdisorg)
  36. #:use-module (gnu packages xiph)
  37. #:use-module (gnu packages xml))
  38. (define-public liblcf
  39. (package
  40. (name "liblcf")
  41. (version "0.6.2")
  42. (source (origin
  43. (method url-fetch)
  44. (uri (string-append
  45. "https://easyrpg.org/downloads/player/" version
  46. "/liblcf-" version ".tar.gz"))
  47. (sha256
  48. (base32
  49. "0n2k4brd264jg9p6918x7dnb2iimpzjh8q3v1fws58450xbgnkqc"))))
  50. (build-system gnu-build-system)
  51. (native-inputs
  52. `(("pkg-config" ,pkg-config)))
  53. (propagated-inputs
  54. ;; Required by 'liblcf.pc'.
  55. `(("expat" ,expat)
  56. ("icu" ,icu4c)))
  57. (home-page "https://easyrpg.org/")
  58. (synopsis "Library to handle RPG Maker 2000 and 2003 game data")
  59. (description
  60. "@code{liblcf} is a library to handle RPG Maker 2000 and 2003 game data.
  61. It can read and write LCF and XML files.")
  62. ;; It includes a copy of Boost Preprocessor Cat and Stringize (boost-1.0):
  63. ;; src/boost/preprocessor/config.hpp
  64. ;; src/boost/preprocessor/cat.hpp
  65. ;; src/boost/preprocessor/stringize.hpp
  66. ;; and a copy of inih (bsd-3):
  67. ;; src/ini.h
  68. ;; src/ini.cpp
  69. ;; src/inireader.h
  70. ;; src/inireader.cpp
  71. ;; TODO: Unbundle them.
  72. (license license:expat)))
  73. (define-public easyrpg-player
  74. (package
  75. (name "easyrpg-player")
  76. (version "0.6.2.3")
  77. (source (origin
  78. (method url-fetch)
  79. (uri (string-append
  80. "https://easyrpg.org/downloads/player/" version
  81. "/easyrpg-player-" version ".tar.gz"))
  82. (sha256
  83. (base32
  84. "1lahbhgyhky0hgd3xwhgg2nm8mfa9p2i1fzxi00561hnk2ya86pm"))))
  85. (build-system gnu-build-system)
  86. (arguments
  87. '(#:configure-flags
  88. (list (string-append "--with-bash-completion-dir="
  89. %output "/etc/bash_completion.d/"))))
  90. (native-inputs
  91. `(("pkg-config" ,pkg-config)))
  92. (inputs
  93. `(("freetype" ,freetype)
  94. ("harfbuzz" ,harfbuzz)
  95. ("liblcf" ,liblcf)
  96. ("libpng" ,libpng)
  97. ("libsndfile" ,libsndfile)
  98. ("libvorbis" ,libvorbis)
  99. ("libxmp" ,libxmp)
  100. ("mpg123" ,mpg123)
  101. ("opusfile" ,opusfile)
  102. ("pixman" ,pixman)
  103. ("sdl2-mixer" ,sdl2-mixer)
  104. ("sdl2" ,sdl2)
  105. ("speexdsp" ,speexdsp)
  106. ("wildmidi" ,wildmidi)
  107. ("zlib" ,zlib)))
  108. (home-page "https://easyrpg.org/")
  109. (synopsis "Play RPG Maker 2000 and 2003 games")
  110. (description
  111. "EasyRPG Player is a game interpreter to play RPG Maker 2000, 2003 and
  112. EasyRPG games. It uses the LCF parser library (liblcf) to read RPG Maker game
  113. data.")
  114. ;; It bundles FMMidi YM2608 FM synthesizer emulator (bsd-3):
  115. ;; src/midisynth.h
  116. ;; src/midisynth.cpp
  117. ;; and PicoJSON JSON parser/serializer (bsd-2):
  118. ;; src/picojson.h
  119. ;; TODO: Unbundle them.
  120. (license license:gpl3+)))