dunst.scm 3.6 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2015, 2017, 2018 Alex Kost <alezost@gmail.com>
  3. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
  5. ;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
  6. ;;; Copyright © 2021 Alexandru-Sergiu Marton <brown121407@posteo.ro>
  7. ;;;
  8. ;;; This file is part of GNU Guix.
  9. ;;;
  10. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  11. ;;; under the terms of the GNU General Public License as published by
  12. ;;; the Free Software Foundation; either version 3 of the License, or (at
  13. ;;; your option) any later version.
  14. ;;;
  15. ;;; GNU Guix is distributed in the hope that it will be useful, but
  16. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  17. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. ;;; GNU General Public License for more details.
  19. ;;;
  20. ;;; You should have received a copy of the GNU General Public License
  21. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  22. (define-module (gnu packages dunst)
  23. #:use-module (guix packages)
  24. #:use-module (guix git-download)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (guix utils)
  27. #:use-module ((guix licenses) #:prefix license:)
  28. #:use-module (gnu packages base)
  29. #:use-module (gnu packages freedesktop)
  30. #:use-module (gnu packages glib)
  31. #:use-module (gnu packages gnome)
  32. #:use-module (gnu packages gtk)
  33. #:use-module (gnu packages perl)
  34. #:use-module (gnu packages pkg-config)
  35. #:use-module (gnu packages xorg))
  36. (define-public dunst
  37. (package
  38. (name "dunst")
  39. (version "1.6.1")
  40. (source (origin
  41. (method git-fetch)
  42. (uri (git-reference
  43. (url "https://github.com/dunst-project/dunst")
  44. (commit (string-append "v" version))))
  45. (file-name (git-file-name name version))
  46. (sha256
  47. (base32
  48. "0lga1kj2vjbj9g9rl93nivngjmk5fkxdxwal8w96x9whwk9jvdga"))))
  49. (build-system gnu-build-system)
  50. (arguments
  51. `(#:tests? #f ; no check target
  52. #:make-flags (list (string-append "CC=" ,(cc-for-target))
  53. (string-append "PREFIX=" %output)
  54. (string-append "SYSCONFDIR=" %output "/etc")
  55. ;; Otherwise it tries to install service file
  56. ;; to "dbus" store directory.
  57. (string-append "SERVICEDIR_DBUS=" %output
  58. "/share/dbus-1/services")
  59. "dunstify")
  60. #:phases (modify-phases %standard-phases
  61. (delete 'configure))))
  62. (native-inputs
  63. `(("pkg-config" ,pkg-config)
  64. ("perl" ,perl) ; for pod2man
  65. ("which" ,which)))
  66. (inputs
  67. `(("dbus" ,dbus)
  68. ("gdk-pixbuf" ,gdk-pixbuf+svg) ; for svg support
  69. ("glib" ,glib)
  70. ("cairo" ,cairo)
  71. ("pango" ,pango)
  72. ("libnotify" ,libnotify) ; for dunstify
  73. ("libx11" ,libx11)
  74. ("libxscrnsaver" ,libxscrnsaver)
  75. ("libxinerama" ,libxinerama)
  76. ("libxrandr" ,libxrandr)
  77. ("libxdg-basedir" ,libxdg-basedir)
  78. ("wayland" ,wayland))) ; for wayland support
  79. (home-page "https://dunst-project.org/")
  80. (synopsis "Customizable and lightweight notification daemon")
  81. (description
  82. "Dunst is a highly configurable and minimalistic notification daemon.
  83. It provides @code{org.freedesktop.Notifications} D-Bus service, so it is
  84. started automatically on the first call via D-Bus.")
  85. (license license:bsd-3)))