cyrus-sasl.scm 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
  3. ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
  4. ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
  5. ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages cyrus-sasl)
  22. #:use-module (gnu packages)
  23. #:use-module (gnu packages autotools)
  24. #:use-module (gnu packages dbm)
  25. #:use-module (gnu packages kerberos)
  26. #:use-module (gnu packages tls)
  27. #:use-module ((guix licenses) #:prefix license:)
  28. #:use-module (guix packages)
  29. #:use-module (guix download)
  30. #:use-module (guix build-system gnu))
  31. (define-public cyrus-sasl
  32. (package
  33. (name "cyrus-sasl")
  34. (version "2.1.27")
  35. (source (origin
  36. (method url-fetch)
  37. (uri (list (string-append
  38. "https://cyrusimap.org/releases/cyrus-sasl-"
  39. version ".tar.gz")
  40. (string-append
  41. "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-"
  42. version ".tar.gz")))
  43. (sha256 (base32
  44. "1m85zcpgfdhm43cavpdkhb1s2zq1b31472hq1w1gs3xh94anp1i6"))
  45. (patches (search-patches "cyrus-sasl-ac-try-run-fix.patch"
  46. "cyrus-sasl-CVE-2019-19906.patch"))))
  47. (build-system gnu-build-system)
  48. (native-inputs
  49. `(("autoconf" ,autoconf)
  50. ("automake" ,automake)
  51. ("libtool" ,libtool)))
  52. (inputs `(("gdbm" ,gdbm)
  53. ("openssl" ,openssl)))
  54. (propagated-inputs
  55. `(;; cyrus-sasl.pc refers to -lkrb5, so propagate it.
  56. ("mit-krb5" ,mit-krb5)))
  57. (arguments
  58. '(#:configure-flags (list (string-append "--with-plugindir="
  59. (assoc-ref %outputs "out")
  60. "/lib/sasl2"))
  61. ;; The 'plugins' directory has shared source files, such as
  62. ;; 'plugin_common.c'. When building the shared libraries there, libtool
  63. ;; ends up doing "ln -s plugin_common.lo plugin_common.o", which can
  64. ;; fail with EEXIST when building things in parallel.
  65. #:parallel-build? #f
  66. #:phases
  67. (modify-phases %standard-phases
  68. (add-after 'unpack 'autogen
  69. (lambda _
  70. (invoke "autoreconf" "-vif"))))))
  71. (synopsis "Simple Authentication Security Layer implementation")
  72. (description
  73. "SASL (Simple Authentication Security Layer) is an Internet
  74. standards-track method for remote computers to authenticate. The Cyrus SASL
  75. library makes supporting various SASL mechanisms easy for both client and
  76. server writers.")
  77. (license (license:non-copyleft "file://COPYING"
  78. "See COPYING in the distribution."))
  79. (home-page "https://cyrusimap.org/sasl/")))