autogen.scm 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2013, 2014 Eric Bavier <bavier@member.fsf.org>
  3. ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
  4. ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
  5. ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
  6. ;;;
  7. ;;; This file is part of GNU Guix.
  8. ;;;
  9. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  10. ;;; under the terms of the GNU General Public License as published by
  11. ;;; the Free Software Foundation; either version 3 of the License, or (at
  12. ;;; your option) any later version.
  13. ;;;
  14. ;;; GNU Guix is distributed in the hope that it will be useful, but
  15. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  16. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  17. ;;; GNU General Public License for more details.
  18. ;;;
  19. ;;; You should have received a copy of the GNU General Public License
  20. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  21. (define-module (gnu packages autogen)
  22. #:use-module (guix packages)
  23. #:use-module (guix licenses)
  24. #:use-module (guix download)
  25. #:use-module (guix build-system gnu)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages perl)
  28. #:use-module (gnu packages pkg-config)
  29. #:use-module (gnu packages base)
  30. #:use-module (gnu packages guile))
  31. (define-public autogen
  32. (package
  33. (name "autogen")
  34. (version "5.18.16")
  35. (source
  36. (origin
  37. (method url-fetch)
  38. (uri (string-append "mirror://gnu/autogen/rel" version
  39. "/autogen-" version ".tar.xz"))
  40. (sha256
  41. (base32 "16mlbdys8q4ckxlvxyhwkdnh1ay9f6g0cyp1kylkpalgnik398gq"))))
  42. (build-system gnu-build-system)
  43. (native-inputs `(("pkg-config" ,pkg-config)
  44. ("which" ,which)))
  45. (inputs `(("guile" ,guile-2.2)
  46. ("perl" ,perl))) ; for doc generator mdoc
  47. (arguments
  48. '(#:configure-flags
  49. ;; XXX Needed to build 5.18.16. ./configure fails without it:
  50. ;; “Something went wrong bootstrapping makefile fragments for
  51. ;; automatic dependency tracking. Try re-running configure with […]”
  52. (list "--disable-dependency-tracking")
  53. ;; XXX: Parallel tests may cause an indefinite hang with GNU Make 4.3.
  54. #:parallel-tests? #f
  55. #:phases
  56. (modify-phases %standard-phases
  57. (add-before 'patch-source-shebangs 'patch-test-scripts
  58. (lambda _
  59. (let ((sh (which "sh")))
  60. (substitute*
  61. (append (find-files "agen5/test" "\\.test$")
  62. (find-files "autoopts/test" "\\.(test|in)$"))
  63. (("/bin/sh") sh))
  64. #t))))))
  65. (home-page "https://www.gnu.org/software/autogen/")
  66. (synopsis "Automated program generator")
  67. (description
  68. "AutoGen is a program to ease the maintenance of programs that contain
  69. large amounts of repetitive text. It automates the construction of these
  70. sections of the code, simplifying the task of keeping the text in sync. It
  71. also includes an add-on package called AutoOpts, which is specialized for the
  72. maintenance and documentation of program options.")
  73. (license gpl3+)))