anthy.scm 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
  3. ;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages anthy)
  20. #:use-module (guix licenses)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu))
  24. (define-public anthy
  25. (package
  26. (name "anthy")
  27. (version "9100h")
  28. (source (origin
  29. (method url-fetch)
  30. ;; The URI does not appear to be easily guessable. For
  31. ;; example, you cannot download version "9100g" simply
  32. ;; by replacing "9100h" in the URI.
  33. (uri "http://dl.osdn.jp/anthy/37536/anthy-9100h.tar.gz")
  34. (sha256
  35. (base32
  36. "0ism4zibcsa5nl77wwi12vdsfjys3waxcphn1p5s7d0qy1sz0mnj"))))
  37. (build-system gnu-build-system)
  38. ;; Anthy also contains elisp modules for using anthy within Emacs.
  39. ;; However, these modules are incompatible with the latest version
  40. ;; of Emacs. This is because they rely on the presence of
  41. ;; last-command-char, which was removed in Emacs 24.3. So, we
  42. ;; don't try to install them here at this time.
  43. (arguments
  44. `(#:phases
  45. (modify-phases %standard-phases
  46. (replace 'check
  47. (lambda _
  48. (with-directory-excursion "test"
  49. (invoke "./anthy" "--all")))))))
  50. (home-page "https://anthy.osdn.jp/")
  51. (synopsis "Japanese input method")
  52. (description "Anthy is a Japanese input method for converting
  53. hiragana text to mixed kana and kanji. It is written in the C
  54. programming language. Anthy stores personal customizations (words it
  55. has learned from the user's input, words the user has explicitly
  56. added, etc.) in the ~/.anthy/ directory. This package contains the
  57. anthy C libraries, the cannadic and alt-cannadic kana dictionaries, as
  58. well as command-line tools for using anthy and managing
  59. dictionaries.")
  60. ;; Most of anthy is lgpl2.1+. However, some files (e.g., from
  61. ;; alt-cannadic) use gpl2. See the file "COPYING" in the anthy
  62. ;; source for details.
  63. (license (list lgpl2.1+ gpl2))))