xmind.SlackBuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. #!/bin/bash
  2. # Slackware build script for XMind
  3. # Copyright 2017 Panagiotis Nikolaou, Culver City, CA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=xmind
  24. VERSION=${VERSION:-8update5}
  25. SRCVERSION=${SRCVERSION:-8-update5}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. set -e
  46. rm -rf $PKG
  47. mkdir -p $TMP $PKG/opt/$PRGNAM $OUTPUT
  48. cd $PKG/opt/$PRGNAM
  49. unzip $CWD/$PRGNAM-$SRCVERSION-linux.zip
  50. if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
  51. rm -rf $PKG/opt/$PRGNAM/XMind_amd64
  52. SRCARCH="_i386"
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. rm -rf $PKG/opt/$PRGNAM/XMind_i386
  55. SRCARCH="_amd64"
  56. else
  57. echo "$ARCH is not supported..."
  58. exit 1
  59. fi
  60. chown -R root:root .
  61. find . -type d -exec chmod 755 {} \;
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  64. -o -perm 511 \) -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  66. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  67. # Remove unused
  68. rm setup.sh
  69. # Change data and configuration stuff location to user's home instead of /opt
  70. sed -e "s|./configuration|@user.home/.xmind/configuration|" \
  71. -e "s|../workspace|@user.home/.xmind/workspace|" \
  72. -i XMind$SRCARCH/XMind.ini
  73. # Add a wrapper to run xmind from /usr/bin
  74. # and copy configuration out of /opt to user's home
  75. mkdir -p $PKG/usr/bin
  76. cat << EOF > $PKG/usr/bin/$PRGNAM
  77. #!/bin/sh
  78. if [ ! -f ~/.xmind/configuration/config.ini ] && [ -f /opt/xmind/XMind$SRCARCH/configuration/config.ini ]; then
  79. mkdir -p ~/.xmind/configuration
  80. cp -r /opt/xmind/XMind$SRCARCH/configuration/* ~/.xmind/configuration/
  81. fi
  82. exec /opt/xmind/XMind$SRCARCH/XMind $@
  83. EOF
  84. chmod 0755 $PKG/usr/bin/$PRGNAM
  85. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  86. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  87. mkdir -p $PKG/usr/share/applications
  88. install -D -m 0644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
  89. mkdir -p $PKG/usr/share/pixmaps
  90. install -D -m 0644 $CWD/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
  91. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  92. mv *.html *.txt $PKG/usr/doc/$PRGNAM-$VERSION
  93. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  94. mkdir -p $PKG/install
  95. cat $CWD/slack-desc > $PKG/install/slack-desc
  96. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  97. cd $PKG
  98. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE