calibre-bin.SlackBuild 2.9 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091
  1. #!/bin/bash
  2. # Slackware build script for calibre-bin
  3. # Copyright 2019-2022, Alexander Verbovetsky, Moscow, Russia
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=calibre-bin
  24. VERSION=${VERSION:-5.44.0}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. ARCH="$( uname -m )"
  30. fi
  31. case "$ARCH" in
  32. i?86) ARCH=i686 ;;
  33. arm*) ARCH=arm ;;
  34. esac
  35. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  36. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  37. exit 0
  38. fi
  39. TMP=${TMP:-/tmp/SBo}
  40. PKG=$TMP/package-$PRGNAM
  41. OUTPUT=${OUTPUT:-/tmp}
  42. set -e
  43. rm -rf $PKG
  44. mkdir -p $TMP $PKG $OUTPUT
  45. cd $PKG
  46. mkdir -p opt/calibre usr/bin \
  47. usr/share/{desktop-directories,applications,metainfo,mime/packages,icons/hicolor,zsh/site-functions}
  48. tar xvf $CWD/${PRGNAM%-bin}-$VERSION-$ARCH.txz -C opt/calibre
  49. XDG_DATA_DIRS=$PKG/usr/share XDG_CONFIG_HOME=$PKG/root/.config opt/calibre/calibre_postinstall --root=$PKG/usr
  50. rmdir -p root/.config
  51. shopt -s extglob
  52. rm -r usr/share/{desktop-directories,mime/!(packages)}
  53. shopt -u extglob
  54. rm -f usr/share/applications/mimeinfo.cache
  55. cd usr/bin
  56. for f in $(find . -maxdepth 1 -type l); do
  57. ln -sf "/opt/calibre/${f:2}" .
  58. done
  59. rm calibre-uninstall
  60. cd ../..
  61. chown -R root:root .
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  64. -o -perm 511 \) -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  66. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  67. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  68. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  69. mkdir -p usr/doc/$PRGNAM-$VERSION
  70. cat $CWD/$PRGNAM.SlackBuild > usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  71. mkdir -p install
  72. cat $CWD/slack-desc > install/slack-desc
  73. cat $CWD/doinst.sh > install/doinst.sh
  74. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE