sunvox.SlackBuild 3.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798
  1. #!/bin/bash
  2. # Slackware build script for Sunvox
  3. # Copyright 2014 fuzzix <fuzzix@fuzzix.org>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=sunvox
  24. VERSION=${VERSION:-1.9.6}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. set -e
  46. rm -rf $PKG
  47. mkdir -p $TMP $PKG $OUTPUT
  48. install -d ${PKG}/usr/{bin,doc,share/{${PRGNAM}/instruments/,${PRGNAM}/effects/,${PRGNAM}/examples/,${PRGNAM}/docs/,${PRGNAM}/curves/,${PRGNAM}/icon/,applications/}}
  49. cd $TMP
  50. rm -rf $PRGNAM
  51. unzip $CWD/$PRGNAM-${VERSION}c.zip
  52. cd $PRGNAM
  53. chown -R root:root .
  54. find -L . \
  55. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  56. -o -perm 511 \) -exec chmod 755 {} \; -o \
  57. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  58. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  59. BINDIR="$TMP/$PRGNAM/$PRGNAM/linux_x86/"
  60. [ $ARCH == 'x86_64' ] && BINDIR="$TMP/$PRGNAM/$PRGNAM/linux_x86_64/"
  61. [ $ARCH == 'arm' ] && BINDIR="$TMP/$PRGNAM/$PRGNAM/raspberry_pi/"
  62. install -Dm755 $BINDIR/${PRGNAM}* $PKG/usr/bin/
  63. if [ $ARCH == 'arm' ]; then
  64. install -dm755 $PKG/lib/
  65. ln -s ld-linux.so.3 $PKG/lib/ld-linux-armhf.so.3
  66. fi
  67. install -Dm644 $CWD/sunvox.desktop $PKG/usr/share/applications/
  68. install -Dm644 $CWD/sunvox.png $PKG/usr/share/sunvox/icon/
  69. for dir in instruments effects examples docs curves ; do
  70. cd "$TMP/$PRGNAM/$dir/"
  71. find . -type d -exec install -d "$PKG/usr/share/$PRGNAM/${dir}/"{} \;
  72. find . -type f -exec install -Dm644 {,"$PKG/usr/share/$PRGNAM/${dir}/"}{} \;
  73. done
  74. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/share/$PRGNAM/docs/$PRGNAM.SlackBuild
  75. ln -s ../share/$PRGNAM/docs/ $PKG/usr/doc/$PRGNAM-$VERSION
  76. mkdir -p $PKG/install
  77. cat $CWD/slack-desc > $PKG/install/slack-desc
  78. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  79. cd $PKG
  80. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE