sbagen.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127
  1. #!/bin/bash
  2. # Slackware build script for sbagen
  3. # Copyright 2016 Ruan K. F <ruan.klein@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # 20220322 bkw: Modified by SlackBuilds.org: fix 32-bit build.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=sbagen
  25. VERSION=${VERSION:-1.4.5}
  26. BUILD=${BUILD:-2}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. DOCS="COPYING.txt ChangeLog.txt README.txt SBAGEN.txt TODO.txt focus.txt focus2.txt holosync.txt theory.txt theory2.txt wave.txt"
  30. BINNAME=${PRGNAM}-bin
  31. # For MP3 and OGG support, set this to "yes"
  32. NONFREE=${NONFREE:-no}
  33. RIVERSOUNDS="sbagen-river-1.4.1.tgz"
  34. if [ -z "$ARCH" ]; then
  35. case "$( uname -m )" in
  36. i?86) ARCH=i586
  37. ;;
  38. x86_64) ARCH=x86_64
  39. ;;
  40. *) ARCH=$(uname -m) # bad
  41. ;;
  42. esac
  43. fi
  44. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  45. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  46. exit 0
  47. fi
  48. TMP=${TMP:-/tmp/SBo}
  49. PKG=$TMP/package-$PRGNAM
  50. OUTPUT=${OUTPUT:-/tmp}
  51. if [ "$ARCH" = "i586" ]; then
  52. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  53. LIBDIRSUFFIX=""
  54. elif [ "$ARCH" = "i686" ]; then
  55. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  56. LIBDIRSUFFIX=""
  57. elif [ "$ARCH" = "x86_64" ]; then
  58. SLKCFLAGS="-O2 -fPIC"
  59. LIBDIRSUFFIX="64"
  60. fi
  61. set -e
  62. rm -rf $PKG
  63. mkdir -p $TMP $PKG $OUTPUT
  64. cd $TMP
  65. rm -rf $PRGNAM-$VERSION
  66. tar xvf $CWD/$PRGNAM-$VERSION.tgz
  67. cd $PRGNAM-$VERSION
  68. chown -R root:root .
  69. find -L . \
  70. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  71. -o -perm 511 \) -exec chmod 755 {} \+ -o \
  72. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  73. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
  74. # 20220323 bkw: for some reason, inlining the calcNow() function
  75. # causes the build to fail on 32-bit.
  76. patch -p1 < $CWD/no_inline_calcnow.diff
  77. if [ "$NONFREE" = "yes" ]; then
  78. LIBS="/usr/lib${LIBDIRSUFFIX}/libvorbisidec.so.1 /usr/lib${LIBDIRSUFFIX}/libmad.so"
  79. OPT="${SLKCFLAGS} -DT_LINUX -DOGG_DECODE -DMP3_DECODE -Wall -s -lm -lpthread"
  80. rm -f river{1,2}.ogg
  81. # original river sounds
  82. tar -xvf $CWD/$RIVERSOUNDS sbagen-1.4.1/river{1,2}.ogg --strip=1
  83. else
  84. LIBS=""
  85. OPT="${SLKCFLAGS} -DT_LINUX -Wall -s -lm -lpthread"
  86. fi
  87. # build
  88. gcc $OPT $LIBS sbagen.c -o $BINNAME || exit 1;
  89. mkdir -p $PKG/usr/{bin,doc/$PRGNAM-$VERSION,share/$PRGNAM/src}
  90. cp -ar $DOCS examples \
  91. $PKG/usr/doc/$PRGNAM-$VERSION
  92. cp -ar scripts river{1,2}.ogg \
  93. $PKG/usr/share/$PRGNAM
  94. # 20220323 bkw: why are we installing the source?
  95. cp -ar *.c mk-* libs \
  96. $PKG/usr/share/$PRGNAM/src
  97. install -m0755 -oroot -groot $CWD/$PRGNAM $PKG/usr/bin
  98. install -m0755 -oroot -groot $BINNAME $PKG/usr/bin/$BINNAME
  99. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  100. mkdir -p $PKG/install
  101. cat $CWD/slack-desc > $PKG/install/slack-desc
  102. cd $PKG
  103. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE