123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113 |
- #!/bin/bash
- # Slackware build script for wmcliphist
- # Originally written by Shining <email removed>
- # Modified & now maintained by B. Watson <yalhcru@gmail.com>. Original
- # version had no license. Modified version released under the WTFPL. See
- # http://www.wtfpl.net/txt/copying/ for details.
- # 20170223 bkw:
- # - Take over maintenance, update for v2.1.
- # - Fix homepage and download link.
- # - i486 => i586.
- # - Add debian patches for 2.1-2 (minor compile issues).
- # - Fix grammar in README and slack-desc.
- # - Install sample config file in doc dir (as per the man page).
- # - Fix path to docdir in man page.
- # 20170225 bkw:
- # - BUILD=2
- # - Get rid of annoying assertion "'GTK_IS_WIDGET (widget)' failed" warnings
- # - Document annoying bug I don't know how to fix, in BUG.txt
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=wmcliphist
- VERSION=${VERSION:-2.1}
- BUILD=${BUILD:-2}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- mkdir -p $PRGNAM-$VERSION
- cd $PRGNAM-$VERSION
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
- cd dockapps
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- # Patches are from: https://packages.debian.org/sid/wmcliphist
- # Probably not even necessary (they fix compiler warnings), and not
- # complete (they don't fix *all* the warnings).
- for i in $CWD/*.patch; do
- patch -p1 < $i
- done
- # This patch is my own. It removes these annoying warnings:
- # gtk_widget_destroy: assertion 'GTK_IS_WIDGET (widget)' failed
- # Reason for the warnings: gtk_container_remove() already destroys
- # a widget, if there's no other reference to it. So we don't need
- # to then call gtk_widget_destroy() on the same widget. See
- # https://developer.gnome.org/gtk3/unstable/GtkContainer.html#gtk-container-remove
- # This explanation is longer than the patch, sorry about that.
- patch -p1 < $CWD/gtk_assert.diff
- sed -i "/^CFLAGS/s,-pedantic,$SLKCFLAGS," Makefile
- sed -i "s,/usr/share/doc/$PRGNAM,/usr/doc/$PRGNAM-$VERSION," $PRGNAM.1
- make PREFIX=/usr MAN1DIR=/usr/man/man1
- strip $PRGNAM
- make install PREFIX=/usr MAN1DIR=/usr/man/man1 DESTDIR=$PKG
- gzip -9 $PKG/usr/man/man1/$PRGNAM.1
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a AUTHORS COPYING ChangeLog NEWS README ${PRGNAM}rc \
- $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|