recoll.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135
  1. #!/bin/bash
  2. # Slackware build script for recoll
  3. # Written by titopoquito (titopoquito@gmail.com)
  4. # Redistribution and use of this script, with or without modification, is
  5. # permitted provided that the following conditions are met:
  6. #
  7. # 1. Redistributions of this script must retain the above copyright
  8. # notice, this list of conditions and the following disclaimer.
  9. #
  10. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  11. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  12. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  13. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  14. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  15. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  16. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  17. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  18. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  19. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  20. # Modified by the SlackBuilds.org Project
  21. cd $(dirname $0) ; CWD=$(pwd)
  22. PRGNAM=recoll
  23. VERSION=${VERSION:-1.32.0}
  24. BUILD=${BUILD:-1}
  25. TAG=${TAG:-_SBo}
  26. PKGTYPE=${PKGTYPE:-tgz}
  27. if [ -z "$ARCH" ]; then
  28. case "$( uname -m )" in
  29. i?86) ARCH=i586 ;;
  30. arm*) ARCH=arm ;;
  31. *) ARCH=$( uname -m ) ;;
  32. esac
  33. fi
  34. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  35. # the name of the created package would be, and then exit. This information
  36. # could be useful to other scripts.
  37. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  38. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  39. exit 0
  40. fi
  41. TMP=${TMP:-/tmp/SBo}
  42. PKG=$TMP/package-$PRGNAM
  43. OUTPUT=${OUTPUT:-/tmp}
  44. if [ "$ARCH" = "i586" ]; then
  45. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  46. LIBDIRSUFFIX=""
  47. elif [ "$ARCH" = "i686" ]; then
  48. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "x86_64" ]; then
  51. SLKCFLAGS="-O2 -fPIC"
  52. LIBDIRSUFFIX="64"
  53. else
  54. SLKCFLAGS="-O2"
  55. LIBDIRSUFFIX=""
  56. fi
  57. # from the official online documenatation:
  58. #
  59. # --enable-camelcase will enable splitting camelCase words. This is not enabled
  60. # by default as it has the unfortunate side-effect of making some phrase searches
  61. # quite confusing: ie, "MySQL manual" would be matched by "MySQL manual" and
  62. # "my sql manual" but not "mysql manual" (only inside phrase searches).
  63. #
  64. # to use this feature, set ENABLE_CAMELCASE to YES (default is to let it disabled)
  65. ENABLE_CAMELCASE=${ENABLE_CAMELCASE:-"NO"}
  66. if [ "$ENABLE_CAMELCASE" = "YES" ]; then
  67. CAMEL_CASE_CONFIG="--enable-camelcase"
  68. else
  69. CAMEL_CASE_CONFIG=""
  70. fi
  71. set -e
  72. rm -rf $PKG
  73. mkdir -p $TMP $PKG $OUTPUT
  74. cd $TMP
  75. rm -rf $PRGNAM-$VERSION
  76. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  77. cd $PRGNAM-$VERSION
  78. chown -R root:root .
  79. find -L . \
  80. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  81. -o -perm 511 \) -exec chmod 755 {} \; -o \
  82. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  83. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  84. sed -i '1,1i#include <QAbstractItemView>' qtgui/ssearch_w.cpp || exit 1
  85. # Ugly hack, but it seems to work...
  86. sed -i "s|recoll\.pro)|recoll.pro ; sed -i 's, -fno-exceptions,,' Makefile)|" Makefile.in
  87. QMAKE=qmake-qt5 \
  88. CFLAGS="$SLKCFLAGS" \
  89. CXXFLAGS="$SLKCFLAGS" \
  90. ./configure $CAMEL_CASE_CONFIG \
  91. --prefix=/usr \
  92. --libdir=/usr/lib${LIBDIRSUFFIX} \
  93. --sysconfdir=/etc \
  94. --mandir=/usr/man \
  95. --localstatedir=/var \
  96. --enable-recollq \
  97. --build=$ARCH-slackware-linux
  98. make
  99. make install DESTDIR=$PKG
  100. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  101. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  102. find $PKG/usr/man -type f -exec gzip -9 {} \;
  103. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  104. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  105. cp -a ChangeLog COPYING README RECOLL-VERSION.txt $PKG/usr/doc/$PRGNAM-$VERSION
  106. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  107. mkdir -p $PKG/install
  108. cat $CWD/slack-desc > $PKG/install/slack-desc
  109. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  110. cd $PKG
  111. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE