luminance-hdr.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113
  1. #!/bin/bash
  2. # Slackware build script for Luminance HDR
  3. # Copyright 2011 David Spencer, Baildon, West Yorkshire, U.K.
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # 20220222 bkw: Modified by SlackBuilds.org: fix build on 15.0,
  23. # by upgrading to v2.6.0. Also actually strip the binaries, and
  24. # get rid of INSTALL from the doc dir.
  25. # 20220320 bkw: fix build on 32-bit.
  26. cd $(dirname $0) ; CWD=$(pwd)
  27. PRGNAM=luminance-hdr
  28. VERSION=${VERSION:-2.6.0}
  29. BUILD=${BUILD:-1}
  30. TAG=${TAG:-_SBo}
  31. PKGTYPE=${PKGTYPE:-tgz}
  32. if [ -z "$ARCH" ]; then
  33. case "$( uname -m )" in
  34. # SSE2 instructions are now *required* at runtime, so force i686 to alert
  35. # users of older cpus -- not the same thing, but the best we can do :-(
  36. i?86) ARCH=i686 ;;
  37. arm*) ARCH=arm ;;
  38. *) ARCH=$( uname -m ) ;;
  39. esac
  40. fi
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf ${PRGNAM}-${VERSION}
  63. tar xvf $CWD/${PRGNAM}-${VERSION}.tar.bz2
  64. cd ${PRGNAM}-${VERSION}
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \+ -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
  71. # Workround build failure with gcc-g++-4.9.3 and beyond (mangling bug?)
  72. # (fails to link libmvec: "undefined reference to `_ZGVbN4vv_powf'" etc)
  73. export CXX=clang++
  74. # 20220320 bkw: for some reason, the -latomic is needed on 32-bit x86.
  75. # it does no harm on x86_64.
  76. mkdir -p build
  77. cd build
  78. cmake \
  79. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  80. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  81. -DCMAKE_CXX_LINK_FLAGS="-latomic" \
  82. -DCMAKE_INSTALL_PREFIX=/usr \
  83. -DCMAKE_BUILD_TYPE=Release ..
  84. make
  85. make install/strip DESTDIR=$PKG
  86. cd ..
  87. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  88. cp -a \
  89. AUTHORS BUGS Changelog LICENSE README.md README.i18n TODO \
  90. $PKG/usr/doc/$PRGNAM-$VERSION
  91. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  92. mkdir -p $PKG/install
  93. cat $CWD/slack-desc > $PKG/install/slack-desc
  94. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  95. cd $PKG
  96. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE