google-talkplugin.SlackBuild 3.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. #!/bin/bash
  2. # Slackware build script for Google Voice (talkplugin)
  3. # Copyright 2010-2014 Erik Hanson, Minneapolis, MN, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=google-talkplugin
  24. VERSION=${VERSION:-5.41.0.0}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i386 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. case "$ARCH" in
  36. i?86) DEBARCH="i386" ;;
  37. x86_64) DEBARCH="amd64" ;;
  38. *) echo "Not supported" ; exit 1 ;;
  39. esac
  40. # Get the real version, thanks to Fred Richards.
  41. REAL_VER=$(ar p google-talkplugin_current_${DEBARCH}.deb control.tar.gz | tar zxO ./control | grep Version | awk '{print $2}' | cut -d- -f1)
  42. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  43. # the name of the created package would be, and then exit. This information
  44. # could be useful to other scripts.
  45. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  46. echo "$PRGNAM-$REAL_VER-$ARCH-$BUILD$TAG.$PKGTYPE"
  47. exit 0
  48. fi
  49. TMP=${TMP:-/tmp/SBo}
  50. PKG=$TMP/package-$PRGNAM
  51. OUTPUT=${OUTPUT:-/tmp}
  52. set -eu
  53. rm -rf $PKG
  54. mkdir -p $TMP $PKG $OUTPUT
  55. cd $PKG
  56. ar p $CWD/google-talkplugin_current_${DEBARCH}.deb data.tar.gz | tar xvz
  57. chown -R root:root .
  58. find -L . \
  59. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  60. -o -perm 511 \) -exec chmod 755 {} \; -o \
  61. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  62. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  63. chmod 0755 $PKG # Put this back.
  64. rm -rf etc/ opt/google/talkplugin/cron # The cron job is debian/ubuntu only.
  65. # These just aren't necessary, mozilla/plugins/ covers all bases.
  66. for s in firefox iceape iceweasel midbrowser xulrunner xulrunner-addons ; do
  67. rm -rf $PKG/usr/lib/${s}
  68. done
  69. mv ${PKG}/usr/lib/chromium-browser ${PKG}/usr/lib/chromium
  70. if [ "$DEBARCH" = "amd64" ] ; then mv $PKG/usr/lib $PKG/usr/lib64 ; fi
  71. mkdir -p $PKG/usr/doc
  72. mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$REAL_VER
  73. rmdir $PKG/usr/share/doc $PKG/usr/share
  74. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$REAL_VER/$PRGNAM.SlackBuild
  75. mkdir -p $PKG/install
  76. cat $CWD/slack-desc > $PKG/install/slack-desc
  77. cd $PKG
  78. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$REAL_VER-$ARCH-$BUILD$TAG.$PKGTYPE