graphviz.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133
  1. #!/bin/bash
  2. # Slackware build script for graphviz
  3. # Copyright 2022 Yth | Pont-en-Royans, France | yth@ythogtha.org
  4. # Copyright 2007 Robby Workman <rworkman@slackbuilds.org>
  5. # Copyright 2011 Heinz Wiesinger <pprkut@slackbuilds.org>
  6. # Copyright 2013-2017 Audrius Kažukauskas <audrius@neutrino.lt>
  7. # All rights reserved.
  8. #
  9. # Redistribution and use of this script, with or without modification, is
  10. # permitted provided that the following conditions are met:
  11. #
  12. # 1. Redistributions of this script must retain the above copyright
  13. # notice, this list of conditions and the following disclaimer.
  14. #
  15. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  16. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  17. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  18. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  19. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  20. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  21. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  22. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  23. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  24. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  25. cd $(dirname $0) ; CWD=$(pwd)
  26. PRGNAM=graphviz
  27. VERSION=${VERSION:-3.0.0}
  28. BUILD=${BUILD:-2}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. if [ "$ARCH" = "i586" ]; then
  49. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "i686" ]; then
  52. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  53. LIBDIRSUFFIX=""
  54. elif [ "$ARCH" = "x86_64" ]; then
  55. SLKCFLAGS="-O2 -fPIC"
  56. LIBDIRSUFFIX="64"
  57. else
  58. SLKCFLAGS="-O2"
  59. LIBDIRSUFFIX=""
  60. fi
  61. set -e
  62. rm -rf $PKG
  63. mkdir -p $TMP $PKG $OUTPUT
  64. cd $TMP
  65. rm -rf $PRGNAM-$VERSION
  66. tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
  67. cd $PRGNAM-$VERSION
  68. chown -R root:root .
  69. find -L . \
  70. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  71. -o -perm 511 \) -exec chmod 755 {} \; -o \
  72. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  73. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  74. ./autogen.sh
  75. CFLAGS="$SLKCFLAGS" \
  76. CXXFLAGS="$SLKCFLAGS" \
  77. LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" \
  78. ./configure \
  79. --prefix=/usr \
  80. --libdir=/usr/lib${LIBDIRSUFFIX} \
  81. --mandir=/usr/man \
  82. --disable-static \
  83. --build=$ARCH-slackware-linux
  84. make
  85. make install-strip DESTDIR=$PKG
  86. # Install config file for PHP.
  87. mkdir -p $PKG/etc/php.d
  88. cat $CWD/graphviz.ini > $PKG/etc/php.d/graphviz.ini.new
  89. find $PKG/usr/man -type f -exec gzip -9 {} \;
  90. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  91. # Remove empty directories of language bindings that are absent.
  92. find $PKG/usr/lib${LIBDIRSUFFIX}/graphviz -depth -type d -empty -exec rmdir {} \;
  93. # Create a "dummy" config file in /usr/lib${LIBDIRSUFFIX}/graphviz so that it
  94. # will be removed when the package is uninstalled. This file is generated by
  95. # the postinstall script and contains information about available plugins, so
  96. # this is (or at least should be) safe.
  97. #
  98. # Write some dummy content to it to avoid
  99. # "Error: /usr/lib64/graphviz/config6 is zero sized, or other read error."
  100. # message during installation.
  101. echo '# Dummy content.' > $PKG/usr/lib${LIBDIRSUFFIX}/graphviz/config6
  102. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  103. cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
  104. mv $PKG/usr/share/$PRGNAM/doc/* $PKG/usr/doc/$PRGNAM-$VERSION
  105. rmdir $PKG/usr/share/$PRGNAM/doc
  106. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  107. rm -f $PKG/usr/lib*/*.la
  108. mkdir -p $PKG/install
  109. cat $CWD/slack-desc > $PKG/install/slack-desc
  110. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  111. cd $PKG
  112. /sbin/makepkg -l y -c n -p $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE