bashmount.SlackBuild 2.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677
  1. #!/bin/bash
  2. # Slackware build script for bashmount
  3. # Copyright 2022 Brandon Pribula BC, Canada
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=bashmount
  24. VERSION=${VERSION:-4.3.2}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. ARCH="noarch"
  29. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  30. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  31. exit 0
  32. fi
  33. TMP=${TMP:-/tmp/SBo}
  34. PKG=$TMP/package-$PRGNAM
  35. OUTPUT=${OUTPUT:-/tmp}
  36. set -e
  37. rm -rf $PKG
  38. mkdir -p $TMP $PKG $OUTPUT
  39. cd $TMP
  40. rm -rf $PRGNAM-$VERSION
  41. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  42. cd $PRGNAM-$VERSION
  43. chown -R root:root .
  44. find -L . \
  45. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  46. -o -perm 511 \) -exec chmod 755 {} \; -o \
  47. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  48. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  49. install -D $PRGNAM $PKG/usr/bin/$PRGNAM
  50. # Install manpage
  51. install -m 644 -D ${PRGNAM}.1 $PKG/usr/man/man1/${PRGNAM}.1
  52. find $PKG/usr/man -type f -exec gzip -9 {} \;
  53. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  54. # Install config to /etc
  55. install -m 644 -D ${PRGNAM}.conf $PKG/etc/${PRGNAM}.conf
  56. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  57. cp -a COPYING NEWS README.md $PKG/usr/doc/$PRGNAM-$VERSION
  58. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  59. mkdir -p $PKG/install
  60. cat $CWD/slack-desc > $PKG/install/slack-desc
  61. cd $PKG
  62. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE