gpsd.SlackBuild 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. #!/bin/bash
  2. # Slackware build script for gpsd
  3. # Copyright 2011 David Spencer, Baildon, West Yorkshire, U.K.
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=gpsd
  24. VERSION=${VERSION:-3.18.1}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i486 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i486" ]; then
  46. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. ENABLELIST=""
  60. set -- $(echo $ENABLE | sed 's/,/ /g')
  61. while [ "$1" != "" ]
  62. do
  63. case "$1" in
  64. *=* )
  65. ENABLELIST+=" $1"
  66. ;;
  67. * )
  68. ENABLELIST+=" $1=yes"
  69. ;;
  70. esac
  71. shift
  72. done
  73. DISABLELIST=""
  74. set -- $(echo $DISABLE | sed 's/,/ /g')
  75. while [ "$1" != "" ]
  76. do
  77. DISABLELIST+=" $1=no"
  78. shift
  79. done
  80. rm -rf $PKG
  81. mkdir -p $TMP $PKG $OUTPUT
  82. cd $TMP
  83. rm -rf $PRGNAM-$VERSION
  84. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  85. cd $PRGNAM-$VERSION
  86. chown -R root:root .
  87. find -L . \
  88. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  89. -o -perm 511 \) -exec chmod 755 {} \; -o \
  90. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  91. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  92. # g++ may throw an 'internal compiler error' in the QT bindings.
  93. # *Nothing* actually uses this, but you can enable it by deleting
  94. # 'qt=no' below (and you should keep the libQgpsmm manpage)
  95. CFLAGS=$SLKCFLAGS \
  96. scons \
  97. prefix=/usr \
  98. libdir=/usr/lib${LIBDIRSUFFIX} \
  99. python_libdir=/usr/lib${LIBDIRSUFFIX}/python$(python -c 'import sys; print sys.version[:3]')/site-packages \
  100. pkgconfigdir=/usr/lib${LIBDIRSUFFIX}/pkgconfig \
  101. mandir=/usr/man \
  102. chrpath=no \
  103. qt=no \
  104. $ENABLELIST \
  105. $DISABLELIST
  106. DESTDIR=$PKG \
  107. scons \
  108. --implicit-deps-unchanged \
  109. install
  110. # Fix daft permission from upstream
  111. chmod 755 $PKG/usr/bin/gpsprof
  112. # Add a missed file
  113. install -m 0644 gpsinit \
  114. $PKG/usr/sbin/gpsinit
  115. find $PKG/usr/man -type f -exec gzip -9 {} \;
  116. for i in $(find $PKG/usr/man -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  117. # libQgpsmm == qt bindings == not built, so remove the manpage:
  118. rm -f $PKG/usr/man/man3/libQgpsmm.3.gz
  119. install -D -m 0644 $CWD/xgps.desktop \
  120. $PKG/usr/share/applications/xgps.desktop
  121. install -D -m 0644 $CWD/xgpsspeed.desktop \
  122. $PKG/usr/share/applications/xgpsspeed.desktop
  123. install -D -m 0644 packaging/X11/gpsd-logo.png \
  124. $PKG/usr/share/pixmaps/gpsd-logo.png
  125. # Get hotplug config from /etc/rc.d/rc.gpsd.conf not /etc/default/gpsd
  126. sed -i 's;/etc/default/gpsd;/etc/rc.d/rc.gpsd.conf;' gpsd.hotplug
  127. install -D -m 0755 gpsd.hotplug \
  128. $PKG/lib/udev/gpsd.hotplug
  129. mkdir -p $PKG/lib/udev/rules.d
  130. # Comment out all udev rules: the user is expected to enable only the
  131. # rules required (see README)
  132. cat gpsd.rules | \
  133. sed 's/^ATTRS/#&/' \
  134. >$PKG/lib/udev/rules.d/97-gpsd.rules
  135. install -D -m 0644 $CWD/rc.gpsd.new \
  136. $PKG/etc/rc.d/rc.gpsd.new
  137. install -D -m 0644 $CWD/rc.gpsd.conf.new \
  138. $PKG/etc/rc.d/rc.gpsd.conf.new
  139. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  140. cp -a AUTHORS COPYING INSTALL README TODO build.txt $PKG/usr/doc/$PRGNAM-$VERSION
  141. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  142. mkdir -p $PKG/install
  143. cat $CWD/slack-desc > $PKG/install/slack-desc
  144. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  145. cd $PKG
  146. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE