ufraw.SlackBuild 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132
  1. #!/bin/bash
  2. # Slackware Package Build Script for UFRaw (Unidentified Flying Raw)
  3. # Home Page http://ufraw.sourceforge.net/
  4. # Copyright (c) 2007-2015, Nishant Limbachia, Hoffman Estates, IL, USA (nishant _AT_ mnspace _DOT_ net)
  5. # Copyright (c) 2007, Robby Workman <rworkman@slackbuilds.org>
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of script must retain the above copyright notice,
  12. # this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  15. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  16. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  17. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
  18. # CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
  19. # EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  20. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
  21. # PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
  22. # LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
  23. # NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
  24. # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  25. cd $(dirname $0) ; CWD=$(pwd)
  26. PRGNAM="ufraw"
  27. VERSION=${VERSION:-20210427_684af05}
  28. BUILD=${BUILD:-1}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. if [ "${GTK:-yes}" = "yes" ]; then
  49. gtk_option="--with-gtk"
  50. else
  51. gtk_option="--without-gtk"
  52. fi
  53. if [ "$ARCH" = "i586" ]; then
  54. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  55. LIBDIRSUFFIX=""
  56. elif [ "$ARCH" = "i686" ]; then
  57. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  58. LIBDIRSUFFIX=""
  59. elif [ "$ARCH" = "x86_64" ]; then
  60. SLKCFLAGS="-O2 -fPIC"
  61. LIBDIRSUFFIX="64"
  62. else
  63. SLKCFLAGS="-O2"
  64. LIBDIRSUFFIX=""
  65. fi
  66. set -e
  67. rm -rf $TMP/$PRGNAM-$VERSION $PKG
  68. mkdir -p $TMP $PKG $OUTPUT
  69. cd $TMP
  70. tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
  71. cd $TMP/$PRGNAM-$VERSION
  72. chown -R root.root .
  73. find -L . \
  74. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  75. -exec chmod 755 {} \; -o \
  76. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  77. -exec chmod 644 {} \;
  78. autoreconf -fi
  79. CFLAGS="$SLKCFLAGS" \
  80. CXXFLAGS="$SLKCFLAGS" \
  81. ./configure \
  82. --prefix=/usr \
  83. --sysconfdir=/etc \
  84. --libdir=/usr/lib${LIBDIRSUFFIX} \
  85. --localstatedir=/var \
  86. --mandir=/usr/man \
  87. --enable-mime \
  88. --enable-extras \
  89. --enable-dst-correction \
  90. --enable-contrast \
  91. --build=$ARCH-slackware-linux \
  92. $gtk_option
  93. make V=1
  94. make install DESTDIR=$PKG
  95. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  96. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  97. # remove dcraw executable - we have a separate package in SBo which provides this.
  98. rm -f $PKG/usr/bin/dcraw
  99. find $PKG/usr/man -type f -exec gzip -9 {} \;
  100. for i in $(find $PKG/usr/man -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
  101. mkdir -p $PKG/usr/share/{applications,pixmaps}
  102. install -m 0644 ufraw.desktop $PKG/usr/share/applications
  103. install -m 0644 icons/ufraw.png $PKG/usr/share/pixmaps
  104. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  105. cp -a COPYING MANIFEST README TODO $PKG/usr/doc/$PRGNAM-$VERSION
  106. mkdir -p $PKG/install
  107. cat $CWD/slack-desc > $PKG/install/slack-desc
  108. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  109. cd $PKG
  110. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE