123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115 |
- #!/bin/bash
- # Slackware build script for vocoder
- # Written by B. Watson (yalhcru@gmail.com)
- # Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
- # 20211130 bkw: BUILD=3, new-style icons.
- # 20170312 bkw:
- # - actually use SLKCFLAGS
- # - stop fluid from writing to /root/.fltk/
- # - use "-include unistd.h" compiler opt instead of a patch
- # - BUILD=2
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=vocoder
- VERSION=${VERSION:-0.29}
- BUILD=${BUILD:-3}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM
- tar xvf $CWD/$PRGNAM-jack-$VERSION.tar.gz
- cd $PRGNAM
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- sed -i "s,-O2,$SLKCFLAGS -include unistd.h," src/Makefile
- sed -i "/^CFLAGS/s,\$, $SLKCFLAGS -include unistd.h," util/Makefile
- # Override $HOME since fluid insists on writing useless stuff there.
- # In case the user's using ccache, this changes the cache dir, so we
- # put it back like it was (no harm done if user not using ccache).
- CCACHE_DIR=${CCACHE_DIR:-$HOME/.ccache} \
- HOME=$( pwd ) \
- make
- # manual install (no install target in Makefile)
- mkdir -p $PKG/usr/bin
- install -s -m0755 src/$PRGNAM $PKG/usr/bin/$PRGNAM
- # icon made for this slackbuild, by crudely stitching together a generic Tux
- # plus http://openclipart.org/detail/24414/old-style-microphone-by-boobaloo
- for px in 16 32 48 64 128; do
- size=${px}x${px}
- dir=$PKG/usr/share/icons/hicolor/$size/apps
- mkdir -p $dir
- convert -resize $size $CWD/$PRGNAM.png $dir/$PRGNAM.png
- done
- mkdir -p $PKG/usr/share/pixmaps
- ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
- # .desktop written for this slackbuild.
- mkdir -p $PKG/usr/share/applications
- cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a AUTHORS COPYRIGHT README $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- # Only add capability stuff if not disabled:
- if [ "${SETCAP:-yes}" = "yes" ]; then
- cat $CWD/setcap.sh >> $PKG/install/doinst.sh
- # Only allow execution by audio group
- chown root:audio $PKG/usr/bin/$PRGNAM
- chmod 0750 $PKG/usr/bin/$PRGNAM
- fi
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|