123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115 |
- #!/bin/bash
- # Slackware build script for lsmi
- # Written by B. Watson (yalhcru@gmail.com)
- # Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=lsmi
- VERSION=${VERSION:-0.1}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG/usr/bin $OUTPUT
- cd $TMP
- rm -rf $PRGNAM
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
- cd $PRGNAM
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- # all this seddery could have been done with a diff, I just felt like
- # using sed today for some reason.
- # use our flags and install to our directory.
- sed -i \
- -e "s/-g/$SLKCFLAGS/" \
- -e "s,/usr/local/bin,$PKG/usr/bin," \
- -e "s,install ,install -s -m0755 ," \
- Makefile
- # fix typo in --help output
- sed -i 's/thrree/three/' lsmi-mouse.c
- # make keyhack's --help actually work
- sed -i 's/fprintf.*Help.*/usage();/' lsmi-keyhack.c
- # fix possible segfault
- sed -i 's/\(char *prog_buf\)\[4\]/\1[5]/' lsmi-keyhack.c
- # As shipped, only lsmi-monterey supports POSIX realtime scheduling. This
- # patch (by the SlackBuild author) adds the -R option to the other lsmi-*
- # binaries.
- patch -p1 < $CWD/rtprio.diff
- make
- make install
- # man pages came from the Musix project:
- # ftp://musix.ourproject.org/pub/musix/deb/lsmi_0.1-1_i386.deb
- # Modified a bit: fixed a typo, rewrote section
- # about realtime scheduling so it applies to Slackware.
- mkdir -p $PKG/usr/man/man1
- cd $CWD/man
- for i in *; do
- gzip -9c < $i > $PKG/usr/man/man1/$i.gz
- done
- cd -
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- if [ "${SETCAP:-yes}" = "yes" ]; then
- cat $CWD/setcap.sh >> $PKG/install/doinst.sh
- for i in lsmi-joystick lsmi-keyhack lsmi-monterey lsmi-mouse; do
- chown root:audio $PKG/usr/bin/$i
- chmod 0750 $PKG/usr/bin/$i
- done
- fi
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|