gnucash.SlackBuild 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166
  1. #!/bin/bash
  2. # Slackware build script for gnucash
  3. # Copyright 2015 Trayan Denev, tdenev@gmail.com
  4. # This version Copyright 2018-2022 Lenard Spencer <lenardrspencer@gmail.com>
  5. # All rights reserved.
  6. #
  7. # Redistribution and use of this script, with or without modification, is
  8. # permitted provided that the following conditions are met:
  9. #
  10. # 1. Redistributions of this script must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  14. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  15. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  16. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  17. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  18. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  19. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  21. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  22. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=gnucash
  25. VERSION=${VERSION:-4.11}
  26. BUILD=${BUILD:-2}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. PACKAGER=${PACKAGER:-"Just Another Slacker"}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. elif [ "$ARCH" = "s390" ]; then
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. elif [ "$ARCH" = "arm" ]; then
  60. SLKCFLAGS="-O2 -march=armv4t"
  61. LIBDIRSUFFIX=""
  62. else
  63. SLKCFLAGS="-O2"
  64. LIBDIRSUFFIX=""
  65. fi
  66. if [ "$DBI" = "yes" ]; then
  67. DBIARGS="-DWITH_SQL=ON -DGNC_DBD_DIR=/usr/lib${LIBDIRSUFFIX}/dbd/"
  68. echo " building with SQL integration enabled"
  69. sleep 1
  70. else
  71. DBIARGS="-DWITH_SQL=OFF "
  72. fi
  73. if [ "$OFX" = "yes" ]; then
  74. OFXBANKING="-DWITH_OFX=ON"
  75. echo " building with OFX enabled"
  76. sleep 1
  77. else
  78. OFXBANKING="-DWITH_OFX=OFF"
  79. fi
  80. if [ "$AQ" = "yes" ]; then
  81. AQBANKING="-DWITH_AQBANKING=ON"
  82. echo " building with aqbanking enabled"
  83. sleep 1
  84. else
  85. AQBANKING="-DWITH_AQBANKING=OFF"
  86. fi
  87. if [ "${WITHPYTHON}" = "yes" ]; then
  88. W_PYTHON="-DWITH_PYTHON=ON"
  89. echo " building with Python bindings enabled"
  90. sleep 1
  91. else
  92. W_PYTHON="-DWITH_PYTHON=OFF"
  93. fi
  94. set -e
  95. rm -rf $PKG
  96. mkdir -p $TMP $PKG $OUTPUT
  97. cd $TMP
  98. rm -rf $PRGNAM-$VERSION
  99. tar xvf $CWD/$PRGNAM-${VERSION}.tar.bz2
  100. cd $PRGNAM-$VERSION
  101. chown -R root:root .
  102. find -L . \
  103. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  104. -o -perm 511 \) -exec chmod 755 {} \; -o \
  105. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  106. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  107. mkdir -p build
  108. cd build
  109. cmake \
  110. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  111. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  112. -DCMAKE_INSTALL_PREFIX=/usr \
  113. -DLIBDIR=/usr/lib${LIBDIRSUFFIX} \
  114. -DSYSCONFDIR=/etc \
  115. -DCOMPILE_GSCHEMAS=OFF \
  116. $DBIARGS \
  117. $W_PYTHON \
  118. $OFXBANKING \
  119. $AQBANKING \
  120. -GNinja \
  121. -DGNUCASH_BUILD_ID="$VERSION `date -I` by $PACKAGER" \
  122. -DCMAKE_BUILD_TYPE=release ..
  123. "${NINJA:=ninja}"
  124. DESTDIR="$PKG" $NINJA install
  125. cd ..
  126. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  127. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  128. mv $PKG/usr/share/man/ $PKG/usr/
  129. find $PKG/usr/man -type f -exec gzip -9 {} \;
  130. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  131. # Don't clobber this
  132. mv $PKG/etc/gnucash/environment $PKG/etc/gnucash/environment.new
  133. mkdir -p $PKG/usr/doc
  134. mv $PKG/usr/share/doc/$PRGNAM $PKG/usr/doc/$PRGNAM-$VERSION
  135. # Remove all those old ChangeLogs:
  136. rm $PKG/usr/doc/$PRGNAM-$VERSION/ChangeLog.{1,2}*
  137. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  138. rmdir $PKG/usr/share/doc
  139. mkdir -p $PKG/install
  140. cat $CWD/slack-desc > $PKG/install/slack-desc
  141. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  142. cd $PKG
  143. /sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE