qrq.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. #!/bin/bash
  2. # SlackBuild script for qrq.
  3. #
  4. # Copyright 2010 Howard Pepper <h_pepper {at} bellsouth [dot] net>
  5. # Copyright 2017 Nate Bargmann <n0nb@arrl.net>
  6. # Copyright 2020 JK Wood <joshuakwood@gmail.com>
  7. # All rights reserved.
  8. #
  9. # Redistribution and use of this script, with or without modification, is
  10. # permitted provided that the following conditions are met:
  11. #
  12. # 1. Redistributions of this script must retain the above copyright
  13. # notice, this list of conditions and the following disclaimer.
  14. #
  15. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  16. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  17. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  18. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  19. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  20. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  21. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  22. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  23. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  24. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  25. cd $(dirname $0) ; CWD=$(pwd)
  26. PRGNAM=qrq
  27. VERSION=${VERSION:-0.3.3}
  28. BUILD=${BUILD:-1}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. if [ "$ARCH" = "i586" ]; then
  49. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "i686" ]; then
  52. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  53. LIBDIRSUFFIX=""
  54. elif [ "$ARCH" = "x86_64" ]; then
  55. SLKCFLAGS="-O2 -fPIC"
  56. LIBDIRSUFFIX="64"
  57. else
  58. SLKCFLAGS="-O2"
  59. LIBDIRSUFFIX=""
  60. fi
  61. set -e
  62. rm -rf $PKG
  63. mkdir -p $TMP $PKG $OUTPUT
  64. cd $TMP
  65. rm -rf $PRGNAM-$VERSION
  66. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  67. cd $PRGNAM-$VERSION
  68. chown -R root:root .
  69. find -L . \
  70. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  71. -o -perm 511 \) -exec chmod 755 {} \; -o \
  72. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  73. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  74. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  75. mkdir -p $PKG/usr/bin
  76. mkdir -p $PKG/usr/man/man1
  77. sed -i Makefile \
  78. -e "s|^CFLAGS\:=\$(CFLAGS)|CFLAGS:=$SLKCFLAGS|" \
  79. -e "s|/share/man|/man|g" \
  80. -e "s|\(^\s\+LDFLAGS:=\$(LDFLAGS)\) \(-lpulse-simple\)|\1 -lpthread \2|"
  81. # Makefile defaults: USE_PA=YES USE_CA=NO OSX_PLATFORM=NO OSX_BUNDLE=NO
  82. # For OSS support: make USE_PA=NO
  83. make
  84. make install DESTDIR=$PKG/usr
  85. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  86. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  87. cp -a AUTHORS COPYING ChangeLog README $PKG/usr/doc/$PRGNAM-$VERSION
  88. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  89. find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
  90. gzip -9 $PKG/usr/man/man?/*.?
  91. mkdir -p $PKG/install
  92. cat $CWD/slack-desc > $PKG/install/slack-desc
  93. cd $PKG
  94. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE