1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798 |
- #!/bin/bash
- #
- # Slackware build script for Screenfetch.
- #
- # Copyright 2012-2017 Bojan Popovic, Belgrade, Serbia, <bocke@slackware-srbija.org>.
- # Copyright 2017-2020 Edinaldo P. Silva, Rio de Janeiro, Brazil.
- # Copyright Jefferson Rocha, Curitiba, Brazil.
- #
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- #########################################################################
- # ChangeLog
- #
- # IMPORTANT: update this if you change this script!)
- #########################################################################
- #
- # 1.0 15-DEC-2012 Added (ver. 2.7.5)
- # 1.1 08-JUL-2013 Updated to a new upstream ver. 3.0.5. Fixes Slack64
- # detection.
- # 1.2 06-DEC-2013 Updated to a new upstream ver. 3.2.2.
- # 1.3 23-JUN-2014 Changed source URL (willysr).
- # 1.4 25-JUN-2014 Updated slack-desc (willysr).
- # 1.5 23-JUL-2014 Updated to a new upstream ver. 3.5.0.
- # 1.6 07-DEC-2014 Updated to a new upstream ver. 3.6.5
- # 1.7 30-JAN-2015 Added a source alternative (willysr).
- # 1.8 31-JAN-2015 Updated changelog. Synced changelog to git history.
- # Updated changelog formating. Updated tar extraction line
- # to eliminate (harmless but annoying) extraction errors.
- # 1.9 27-MAR-2017 Updated for version 3.8.0. Added a manpage.
- # 2.0 20-JUNE-2020 Updated to a new upstream ver. 3.9.1.
- # Added Double quotes in variables.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM="screenfetch"
- SRCNAM="screenFetch"
- VERSION="${VERSION:-3.9.1}"
- BUILD="${BUILD:-1}"
- TAG="${TAG:-_SBo}"
- PKGTYPE=${PKGTYPE:-tgz}
- ARCH="noarch"
- DOCS="CHANGELOG COPYING README.mkdn TODO"
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP="${TMP:-/tmp/SBo}"
- PKG="$TMP/package-$PRGNAM"
- OUTPUT="${OUTPUT:-/tmp}"
- set -e
- rm -rf "$PKG"
- mkdir -p "$TMP" "$PKG" "$OUTPUT"
- cd "$TMP"
- rm -rf "$PRGNAM-$VERSION"
- tar xvf "$CWD/$SRCNAM-$VERSION.tar.gz"
- mv "$SRCNAM-$VERSION" "$PRGNAM-$VERSION"
- cd "$PRGNAM-$VERSION"
- install -m 755 -D "$PRGNAM-dev" "$PKG/usr/bin/$PRGNAM"
- mkdir -p "$PKG/usr/man/man1"
- install -m 644 screenfetch.1 "$PKG/usr/man/man1"
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- chmod 644 $DOCS; cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
- cat "$CWD/$PRGNAM.SlackBuild" > "$PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild"
- mkdir -p "$PKG/install"
- cat "$CWD/slack-desc" > "$PKG/install/slack-desc"
- cd "$PKG"
- /sbin/makepkg -l y -c n "$OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
|