fvwm95.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139
  1. #!/bin/bash
  2. # Slackware build script for fvwm95
  3. # Copyright 2014 Tomasz Konojacki <me@xenu.tk>
  4. # Copyright 2020 Logan Rathbone <poprocks@gmail.com>
  5. #
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=fvwm95
  26. VERSION=${VERSION:-2.0.43f}
  27. BUILD=${BUILD:-3}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. rm -rf $PKG
  62. mkdir -p $TMP $PKG $OUTPUT
  63. cd $TMP
  64. rm -rf $PRGNAM-$VERSION
  65. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  66. cd $PRGNAM-$VERSION
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. # Apply patch to make compilation possible
  74. patch -p1 < $CWD/fvwm95.patch
  75. # Apply patch to repair FvwmTaskbar 06/2022
  76. patch -p1 < $CWD/fvwm95.new.patch
  77. CFLAGS="$SLKCFLAGS" \
  78. CXXFLAGS="$SLKCFLAGS" \
  79. ./configure \
  80. --prefix=/usr \
  81. --libdir=/usr/lib${LIBDIRSUFFIX} \
  82. --sysconfdir=/etc \
  83. --localstatedir=/var \
  84. --mandir=/usr/man \
  85. --build=$ARCH-slackware-linux
  86. make
  87. DESTDIR=$PKG make install
  88. # copy xinitrc
  89. mkdir -p $PKG/etc/X11/xinit
  90. install -m 755 $CWD/xinitrc.fvwm95 $PKG/etc/X11/xinit
  91. # rename xpmroot
  92. mv $PKG/usr/bin/xpmroot $PKG/usr/bin/xpmroot95
  93. mv $PKG/usr/man/man1/xpmroot.1 $PKG/usr/man/man1/xpmroot95.1
  94. # rename manpages
  95. for m in $PKG/usr/man/man1/Fvwm* ; do
  96. mv $m `echo $m | sed -r 's/Fvwm/Fvwm95/'`
  97. done
  98. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  99. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  100. find $PKG/usr/man -type f -exec gzip -9 {} \;
  101. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  102. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  103. cp -a Changelog README GPL INSTALL README.rouat fvwm-StackingOrder.html \
  104. FvwmTaskBar-plugins.patch.README $PKG/usr/doc/$PRGNAM-$VERSION
  105. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  106. # plop the old Slackware <= 10.0 default config into /usr/doc as a little Easter Egg
  107. cat $CWD/fvwm95rc-slack10_0.in | sed -e "s,@libdir@,/usr/lib${LIBDIRSUFFIX},g" \
  108. > $PKG/usr/doc/$PRGNAM-$VERSION/fvwm95rc-slack10_0
  109. # ... this also needs to be there for the Start button to work:
  110. install -m 644 $CWD/fvwm95-menu.xpm \
  111. $PKG/usr/lib${LIBDIRSUFFIX}/X11/pixmaps/fvwm95-menu.xpm
  112. mkdir -p $PKG/install
  113. cat $CWD/slack-desc > $PKG/install/slack-desc
  114. cd $PKG
  115. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE