xmms-cue.SlackBuild 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145
  1. #!/bin/bash
  2. #
  3. # Slackware build script for VirtualCue plugin for XMMS 1.x.
  4. #
  5. # Copyright 2020 by Jay, Seattle, WA.
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions, and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=xmms-cue
  26. SRCNAM=VirtualCueXmms
  27. VERSION=${VERSION:-0.2}
  28. BUILD=${BUILD:-1}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # Caveat emptor
  39. case "$ARCH" in
  40. i?86) ;;
  41. x86_64) ;;
  42. *) echo -e "\nBuild for $ARCH is untested!!"
  43. echo -e "Press Ctrl-C within ten seconds to abort,"
  44. echo -e "or press ENTER to continue at your own risk.\n"
  45. read -t 10 PLACEHOLDER ;;
  46. esac
  47. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  48. # the name of the created package would be, and then exit. This information
  49. # could be useful to other scripts.
  50. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  51. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  52. exit 0
  53. fi
  54. TMP=${TMP:-/tmp/SBo}
  55. PKG=$TMP/package-$PRGNAM
  56. OUTPUT=${OUTPUT:-/tmp}
  57. if [ "$ARCH" = "i586" ]; then
  58. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  59. LIBDIRSUFFIX=""
  60. elif [ "$ARCH" = "i686" ]; then
  61. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  62. LIBDIRSUFFIX=""
  63. elif [ "$ARCH" = "x86_64" ]; then
  64. SLKCFLAGS="-O2 -fPIC"
  65. LIBDIRSUFFIX="64"
  66. else
  67. SLKCFLAGS="-O2"
  68. LIBDIRSUFFIX=""
  69. fi
  70. set -e
  71. rm -rf $PKG
  72. mkdir -p $TMP $PKG $OUTPUT
  73. cd $TMP
  74. rm -rf $SRCNAM
  75. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  76. cd $SRCNAM
  77. chown -R root:root .
  78. find -L . \
  79. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  80. -o -perm 511 \) -exec chmod 755 {} \; -o \
  81. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  82. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  83. # The object file CueParser.o is 32-bit.
  84. # Thus, it must be recompiled for
  85. # 64-bit build to work.
  86. case "$ARCH" in
  87. i?86) ;;
  88. *) cd Cueparser
  89. gcc -v -g $SLKCFLAGS -c CueParser.c
  90. cd .. ;;
  91. esac
  92. # Compile general plugin
  93. cd GeneralPlayer
  94. CFLAGS="$SLKCFLAGS" \
  95. ./configure \
  96. --prefix=/usr \
  97. --libdir=/usr/lib${LIBDIRSUFFIX} \
  98. --build=$ARCH-slackware-linux
  99. sed -i "6s/-O/$SLKCFLAGS/" Makefile
  100. sed -i "10i\
  101. INSTALLPATH = $PKG\/usr\/lib${LIBDIRSUFFIX}\/xmms\/General" Makefile
  102. make
  103. make install
  104. # Compile input plugin
  105. cd ../InPlayer
  106. CFLAGS="$SLKCFLAGS" \
  107. ./configure \
  108. --prefix=/usr \
  109. --libdir=/usr/lib${LIBDIRSUFFIX} \
  110. --build=$ARCH-slackware-linux
  111. sed -i "6s/-O/$SLKCFLAGS/" Makefile
  112. sed -i "10i\
  113. INSTALLPATH = $PKG\/usr\/lib${LIBDIRSUFFIX}\/xmms\/Input" Makefile
  114. make
  115. make install
  116. find $PKG -print0 | xargs -0 file | grep -e "shared object" | grep ELF \
  117. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  118. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  119. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  120. cat $TMP/$SRCNAM/README > $PKG/usr/doc/$PRGNAM-$VERSION/README
  121. cat $TMP/$SRCNAM/TODO > $PKG/usr/doc/$PRGNAM-$VERSION/TODO
  122. mkdir -p $PKG/install
  123. cat $CWD/slack-desc > $PKG/install/slack-desc
  124. cd $PKG
  125. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE