x265.SlackBuild 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172
  1. #!/bin/bash
  2. # Slackware build script for x265
  3. # Copyright 2014-2020 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=x265
  24. VERSION=${VERSION:-3.5}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf ${PRGNAM}_${VERSION}
  63. tar xvf $CWD/${PRGNAM}_${VERSION}.tar.gz
  64. cd ${PRGNAM}_${VERSION}
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \; -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  71. for d in 8 $([ "$ARCH" = "x86_64" ] && echo "10 12"); do
  72. if [[ -d build-$d ]]; then
  73. rm -rf build-$d
  74. fi
  75. mkdir build-$d
  76. done
  77. if [ "$ARCH" = "x86_64" ]; then
  78. cd build-12
  79. cmake \
  80. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  81. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  82. -DCMAKE_INSTALL_PREFIX=/usr \
  83. -DLIB_INSTALL_DIR=lib${LIBDIRSUFFIX} \
  84. -DHIGH_BIT_DEPTH=ON \
  85. -DMAIN12=ON \
  86. -DEXPORT_C_API=OFF \
  87. -DENABLE_CLI=OFF \
  88. -DENABLE_SHARED=OFF \
  89. -DCMAKE_BUILD_TYPE=Release ../source
  90. make
  91. cd ../build-10
  92. cmake \
  93. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  94. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  95. -DCMAKE_INSTALL_PREFIX=/usr \
  96. -DLIB_INSTALL_DIR=lib${LIBDIRSUFFIX} \
  97. -DHIGH_BIT_DEPTH=ON \
  98. -DEXPORT_C_API=OFF \
  99. -DENABLE_CLI=OFF \
  100. -DENABLE_SHARED=OFF \
  101. -DCMAKE_BUILD_TYPE=Release ../source
  102. make
  103. cd ../build-8
  104. ln -s ../build-10/libx265.a libx265_main10.a
  105. ln -s ../build-12/libx265.a libx265_main12.a
  106. cmake \
  107. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  108. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  109. -DCMAKE_INSTALL_PREFIX=/usr \
  110. -DLIB_INSTALL_DIR=lib${LIBDIRSUFFIX} \
  111. -DENABLE_SHARED=ON \
  112. -DEXTRA_LIB="x265_main10.a;x265_main12.a" \
  113. -DEXTRA_LINK_FLAGS="-L." \
  114. -DLINKED_10BIT=ON \
  115. -DLINKED_12BIT=ON \
  116. -DCMAKE_BUILD_TYPE=Release ../source
  117. make
  118. else
  119. cd build-8
  120. cmake \
  121. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  122. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  123. -DCMAKE_INSTALL_PREFIX=/usr \
  124. -DLIB_INSTALL_DIR=lib${LIBDIRSUFFIX} \
  125. -DENABLE_SHARED=ON \
  126. -DCMAKE_BUILD_TYPE=Release ../source
  127. make
  128. fi
  129. make install DESTDIR=$PKG
  130. cd ..
  131. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  132. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  133. # Remove static library
  134. rm -f $PKG/usr/lib${LIBDIRSUFFIX}/libx265.a
  135. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  136. cp -a COPYING doc/intra/* $PKG/usr/doc/$PRGNAM-$VERSION
  137. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  138. mkdir -p $PKG/install
  139. cat $CWD/slack-desc > $PKG/install/slack-desc
  140. cd $PKG
  141. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE