spot.SlackBuild 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163
  1. #!/bin/bash
  2. # Slackware build script for spot
  3. # Copyright 2022 Julian Grinblat <julian@dotcore.co.il>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=spot
  24. VERSION=${VERSION:-0.3.3}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. elif [ "$ARCH" = "i686" ]; then
  48. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  49. elif [ "$ARCH" = "x86_64" ]; then
  50. SLKCFLAGS="-O2 -fPIC"
  51. else
  52. SLKCFLAGS="-O2"
  53. fi
  54. set -e
  55. rm -rf $PKG
  56. mkdir -p $TMP $PKG $OUTPUT
  57. cd $TMP
  58. rm -rf $PRGNAM-$VERSION
  59. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  60. cd $PRGNAM-$VERSION
  61. # build offline
  62. # configuration tells cargo to use the configured directory
  63. # for dependencies instead of downloading from crates.io
  64. mkdir .cargo
  65. cat << EOF >> .cargo/config
  66. [source.crates-io]
  67. registry = 'https://github.com/rust-lang/crates.io-index'
  68. replace-with = 'vendored-sources'
  69. [source.vendored-sources]
  70. directory = '$(pwd)/vendor'
  71. EOF
  72. # deps and versions come from Cargo.lock
  73. mkdir vendor
  74. (
  75. cd vendor
  76. grep -h -A 3 "\[\[package\]\]" $(find ../ -maxdepth 1 -mindepth 1 -name Cargo.lock | tr '\n' ' ') | \
  77. sed 's/[[:space:]]*=[[:space:]]*/=/g;s/^--//;s/^\[\[/--\n[[/' | \
  78. awk 'BEGIN { RS = "--\n" ; FS="\n" } { print $2, $3, $4 }' | sed 's/"//g;s/name=//;s/ version=/=/' | \
  79. grep crates\.io-index | sed 's/ source=.*$//' | sort -u | while read -r dep ; do
  80. ver="$(printf "%s\n" "$dep" | cut -d= -f2)"
  81. dep="$(printf "%s\n" "$dep" | cut -d= -f1)"
  82. tar xvf $CWD/$dep-$ver.crate
  83. touch $dep-$ver/.cargo-ok
  84. # generate checksum
  85. {
  86. printf "{\n"
  87. printf ' "files": {\n'
  88. (
  89. cd $dep-$ver
  90. find . -type f -print0 | xargs -0 sha256sum | sed -n '/\.cargo-checksum\.json/!p' | sed 's/\.\///;s/^\([^ ]*\)[[:space:]][[:space:]]*\(.*\)$/"\2":"\1",/'
  91. ) | sed '$ s/,$//'
  92. printf " },\n"
  93. printf ' "package": "'
  94. sha256sum "$CWD/$dep-$ver.crate" | cut -f1 -d' ' | sed 's/$/"/'
  95. printf "}\n"
  96. } > $dep-$ver/.cargo-checksum.json
  97. done
  98. )
  99. chown -R root:root .
  100. find -L . \
  101. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  102. -o -perm 511 \) -exec chmod 755 {} \; -o \
  103. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  104. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  105. mkdir build
  106. cd build
  107. CARGO_HOME=.cargo \
  108. CFLAGS="$SLKCFLAGS" \
  109. CXXFLAGS="$SLKCFLAGS" \
  110. meson .. \
  111. --buildtype=release \
  112. --prefix=/usr \
  113. --strip \
  114. -Doffline=false
  115. "${NINJA:=ninja}"
  116. DESTDIR=$PKG $NINJA install
  117. cd ..
  118. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  119. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  120. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  121. cp -a \
  122. README.md \
  123. ARTISTS \
  124. AUTHORS \
  125. LICENSE \
  126. TRANSLATORS \
  127. doc/doc.pdf \
  128. $PKG/usr/doc/$PRGNAM-$VERSION
  129. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  130. mkdir -p $PKG/install
  131. cat $CWD/slack-desc > $PKG/install/slack-desc
  132. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  133. cd $PKG
  134. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE