flrig.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131
  1. #!/bin/bash
  2. # Slackbuild for flrig
  3. # From slackbuild for fldigi Written by JK Wood joshuakwood@gmail.com
  4. # Modified for flrig by Gustavo Conrad gus3963@gmail.com
  5. # Copyright 2017, 2020 Gustavo Conrad.
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. # Joshua's license:
  25. # Slackbuild is released under the Dog-on-Fire License:
  26. # If use of this script causes your dog to catch on fire,
  27. # you agree to send me five dollars. Or a picture
  28. # of the dog on fire.
  29. # Otherwise, you're on your own. I've tested the script
  30. # on my own computer, and it hasn't broken anything.
  31. # So if it does it on your computer, that falls in
  32. # the realm of "Not my problem."
  33. #
  34. # Of course, if you'll send a bug report to the above
  35. # email address, I may be able to see what you did
  36. # wrong and prevent it from happening in the future.
  37. # In which case, I may just send YOU five dollars.
  38. # Oh, and feel free to copy it and modify it as you
  39. # see fit. Or as I see fit. Or as I fit. Although
  40. # that is unlikely, as I am rather tall.
  41. cd $(dirname $0) ; CWD=$(pwd)
  42. PRGNAM=flrig
  43. VERSION=${VERSION:-1.4.5}
  44. BUILD=${BUILD:-1}
  45. TAG=${TAG:-_SBo}
  46. PKGTYPE=${PKGTYPE:-tgz}
  47. if [ -z "$ARCH" ]; then
  48. case "$( uname -m )" in
  49. i?86) ARCH=i586 ;;
  50. arm*) ARCH=arm ;;
  51. *) ARCH=$( uname -m ) ;;
  52. esac
  53. fi
  54. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  55. # the name of the created package would be, and then exit. This information
  56. # could be useful to other scripts.
  57. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  58. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  59. exit 0
  60. fi
  61. TMP=${TMP:-/tmp/SBo}
  62. PKG=$TMP/package-$PRGNAM
  63. OUTPUT=${OUTPUT:-/tmp}
  64. if [ "$ARCH" = "i586" ]; then
  65. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  66. LIBDIRSUFFIX=""
  67. elif [ "$ARCH" = "i686" ]; then
  68. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  69. LIBDIRSUFFIX=""
  70. elif [ "$ARCH" = "x86_64" ]; then
  71. SLKCFLAGS="-O2 -fPIC"
  72. LIBDIRSUFFIX="64"
  73. else
  74. SLKCFLAGS="-O2"
  75. LIBDIRSUFFIX=""
  76. fi
  77. set -e
  78. rm -rf $PKG
  79. mkdir -p $TMP $PKG $OUTPUT
  80. cd $TMP
  81. rm -rf $PRGNAM-$VERSION
  82. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  83. cd $PRGNAM-$VERSION
  84. chown -R root:root .
  85. find -L . \
  86. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  87. -o -perm 511 \) -exec chmod 755 {} \; -o \
  88. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  89. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  90. CFLAGS="$SLKCFLAGS" \
  91. CXXFLAGS="$SLKCFLAGS" \
  92. ./configure \
  93. --prefix=/usr \
  94. --sysconfdir=/etc \
  95. --localstatedir=/var \
  96. --mandir=/usr/man \
  97. --docdir=/usr/doc/$PRGNAM-$VERSION \
  98. --without-asciidoc \
  99. --build=$ARCH-slackware-linux
  100. make
  101. make install DESTDIR=$PKG
  102. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  103. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  104. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  105. cp -a AUTHORS COPYING ChangeLog README* $PKG/usr/doc/$PRGNAM-$VERSION
  106. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  107. find $PKG/usr/doc -name "Makefile" -exec rm {} \;
  108. find $PKG/usr/doc -type f -exec chmod 644 {} \;
  109. mkdir -p $PKG/install
  110. cat $CWD/slack-desc > $PKG/install/slack-desc
  111. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  112. cd $PKG
  113. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE