zotero.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107
  1. #!/bin/bash
  2. # Slackware build script for zotero
  3. # Copyright 2018-2022 Andrew Payne phalange@komputermatrix.com
  4. # Copyright 2014-2018 Petar Petrov slackalaxy@gmail.com
  5. # All rights reserved.
  6. #
  7. # Redistribution and use of this script, with or without modification, is
  8. # permitted provided that the following conditions are met:
  9. #
  10. # 1. Redistributions of this script must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  14. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  15. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  16. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  17. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  18. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  19. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  21. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  22. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=zotero
  25. SRCNAM=Zotero
  26. VERSION=${VERSION:-6.0.10}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i686 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. set -e
  48. if [ "$ARCH" != "i686" ] && [ "$ARCH" != "x86_64" ]; then
  49. printf "\n\n$ARCH is not supported... \n"
  50. exit 1
  51. fi
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG $OUTPUT
  54. cd $TMP
  55. rm -rf ${SRCNAM}_linux-${ARCH}
  56. tar xvf $CWD/${SRCNAM}-${VERSION}_linux-${ARCH}.tar.bz2
  57. cd ${SRCNAM}_linux-${ARCH}
  58. chown -R root:root .
  59. find -L . \
  60. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  61. -o -perm 511 \) -exec chmod 755 {} \; -o \
  62. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  63. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  64. mkdir -p $PKG/{usr/bin,opt/$PRGNAM}
  65. cp -a * $PKG/opt/$PRGNAM
  66. ln -s /opt/$PRGNAM/zotero $PKG/usr/bin/$PRGNAM
  67. # put the icons in the right place
  68. mkdir -p $PKG/usr/share/icons/hicolor/{16x16,32x32,48x48,256x256,scalable}/apps
  69. cp $PKG/opt/$PRGNAM/chrome/icons/default/default16.png \
  70. $PKG/usr/share/icons/hicolor/16x16/apps/zotero.png
  71. cp $PKG/opt/$PRGNAM/chrome/icons/default/default32.png \
  72. $PKG/usr/share/icons/hicolor/32x32/apps/zotero.png
  73. cp $PKG/opt/$PRGNAM/chrome/icons/default/default48.png \
  74. $PKG/usr/share/icons/hicolor/48x48/apps/zotero.png
  75. cp $PKG/opt/$PRGNAM/chrome/icons/default/default256.png \
  76. $PKG/usr/share/icons/hicolor/256x256/apps/zotero.png
  77. cp $PKG/opt/$PRGNAM/chrome/icons/default/main-window.ico \
  78. $PKG/usr/share/icons/hicolor/scalable/apps/zotero.ico
  79. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  80. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  81. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  82. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  83. mkdir -p $PKG/usr/share/applications
  84. cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
  85. mkdir -p $PKG/install
  86. cat $CWD/slack-desc > $PKG/install/slack-desc
  87. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  88. cd $PKG
  89. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE