scilab.SlackBuild 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103
  1. #!/bin/bash
  2. # Slackware build script for Scilab
  3. # Copyright 2011-2015 Fridrich von Stauffenberg <cancellor2@gmail.com>
  4. # Copyright 2018-2022 Edward W. Koenig ,kingbeowulf@gmail.com>
  5. # All rights reserved.
  6. #
  7. # Redistribution and use of this script, with or without modification, is
  8. # permitted provided that the following conditions are met:
  9. #
  10. # 1. Redistributions of this script must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  14. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  15. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  16. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  17. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  18. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  19. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  21. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  22. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=scilab
  25. VERSION=${VERSION:-6.1.1}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i686 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i686" ]; then
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "x86_64" ]; then
  49. LIBDIRSUFFIX="64"
  50. else
  51. printf "\n\n$ARCH is not supported...\n"
  52. exit 1
  53. fi
  54. set -e
  55. rm -rf $PKG
  56. mkdir -p $OUTPUT $TMP $PKG/opt/$PRGNAM
  57. cd $PKG/opt/$PRGNAM
  58. tar xvf $CWD/$PRGNAM-$VERSION.bin.linux-$ARCH.tar.gz --strip-components=1
  59. chown -R root:root .
  60. sed -i "/^prefix/s/=.*\$/=\/opt\/$PRGNAM/" lib/pkgconfig/$PRGNAM.pc
  61. mkdir -p $PKG/etc/profile.d
  62. cat $CWD/profile.d/$PRGNAM.sh > $PKG/etc/profile.d/$PRGNAM.sh
  63. cat $CWD/profile.d/$PRGNAM.csh > $PKG/etc/profile.d/$PRGNAM.csh
  64. chmod 0755 $PKG/etc/profile.d/*
  65. mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig $PKG/usr/share/{applications,icons,mime}
  66. mv $PKG/opt/$PRGNAM/lib/pkgconfig $PKG/usr/lib${LIBDIRSUFFIX}
  67. mv $PKG/opt/$PRGNAM/share/mime $PKG/usr/share
  68. mv $PKG/opt/$PRGNAM/share/icons $PKG/usr/share
  69. # Remove conflicting libs (esp. for current)
  70. rm -f $PKG/opt/$PRGNAM/lib/thirdparty/redist/libncurses.so
  71. rm -f /$PKG/opt/$PRGNAM/lib/thirdparty/redist/libncurses.so.5
  72. rm -f $PKG/opt/$PRGNAM/lib/thirdparty/redist/libncurses.so.5.7
  73. # fix issues with .desktop files due to upstream bugs
  74. rm -rf $PKG/opt/$PRGNAM/share/applications
  75. mkdir -p $PKG/usr/share/applications
  76. cp -a $CWD/*.desktop $PKG/usr/share/applications
  77. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  78. mv ACKNOWLEDGE* CHANGES* COPYING* README* $PKG/usr/doc/$PRGNAM-$VERSION
  79. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  80. mkdir -p $PKG/install
  81. cat $CWD/slack-desc > $PKG/install/slack-desc
  82. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  83. cd $PKG
  84. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE