samtools.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138
  1. #!/bin/bash
  2. # Slackware build script for samtools
  3. # Copyright 2013-2016 Petar Petrov slackalaxy@gmail.com
  4. # Copyright 2017-2022 Rob van Nues # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=samtools
  24. VERSION=${VERSION:-1.15.1}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. # Some applications still rely on the legacy samtools API instead of using htslib
  29. # exclusively, in that case, install the headers in /usr/include/bam and the static
  30. # libbam library as well by declaring (uncommenting):
  31. #SAMLIB="yes"
  32. # and commenting out:
  33. SAMLIB="no"
  34. # WARNING: this package and htslib both provide a "sam.h" that aren't actually
  35. # compatible with each other. Be extra careful about which file you're actually
  36. # #including when using either of these packages for development work.
  37. if [ -z "$ARCH" ]; then
  38. case "$( uname -m )" in
  39. i?86) ARCH=i586 ;;
  40. arm*) ARCH=arm ;;
  41. *) ARCH=$( uname -m ) ;;
  42. esac
  43. fi
  44. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  45. # the name of the created package would be, and then exit. This information
  46. # could be useful to other scripts.
  47. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  48. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  49. exit 0
  50. fi
  51. TMP=${TMP:-/tmp/SBo}
  52. PKG=$TMP/package-$PRGNAM
  53. OUTPUT=${OUTPUT:-/tmp}
  54. if [ "$ARCH" = "i586" ]; then
  55. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  56. LIBDIRSUFFIX=""
  57. elif [ "$ARCH" = "i686" ]; then
  58. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  59. LIBDIRSUFFIX=""
  60. elif [ "$ARCH" = "x86_64" ]; then
  61. SLKCFLAGS="-O2 -fPIC"
  62. LIBDIRSUFFIX="64"
  63. else
  64. SLKCFLAGS="-O2"
  65. LIBDIRSUFFIX=""
  66. fi
  67. set -e
  68. rm -rf $PKG
  69. mkdir -p $TMP $PKG $OUTPUT
  70. cd $TMP
  71. rm -rf $PRGNAM-$VERSION
  72. tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
  73. cd $PRGNAM-$VERSION
  74. chown -R root:root .
  75. find -L . \
  76. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  77. -o -perm 511 \) -exec chmod 755 {} \; -o \
  78. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  79. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  80. # force linking to installed htslib
  81. rm -r htslib-$VERSION
  82. CFLAGS="$SLKCFLAGS" \
  83. CXXFLAGS="$SLKCFLAGS" \
  84. ./configure \
  85. --prefix=/usr \
  86. --libdir=/usr/lib${LIBDIRSUFFIX} \
  87. --with-htslib=system \
  88. --mandir=/usr/man \
  89. --docdir=/usr/doc/$PRGNAM-$VERSION \
  90. --build=$ARCH-slackware-linux
  91. make
  92. make install DESTDIR=$PKG
  93. mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
  94. cp -a misc/*.lua $PKG/usr/share/$PRGNAM-$VERSION
  95. # include samtools-API if set above
  96. if [ "$SAMLIB" = "yes" ] ; then
  97. mkdir -p $PKG/usr/include/bam
  98. mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}
  99. install -m644 libbam.a "$PKG/usr/lib${LIBDIRSUFFIX}"
  100. install -m644 *.h "$PKG/usr/include/bam"
  101. fi
  102. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  103. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  104. find $PKG/usr/man -type f -exec gzip -9 {} \;
  105. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  106. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  107. cp -a \
  108. AUTHORS LICENSE README INSTALL NEWS examples \
  109. $PKG/usr/doc/$PRGNAM-$VERSION
  110. cp $CWD/README $PKG/usr/doc/$PRGNAM-$VERSION
  111. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  112. mkdir -p $PKG/install
  113. cat $CWD/slack-desc > $PKG/install/slack-desc
  114. cd $PKG
  115. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE