octave.SlackBuild 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151
  1. #!/bin/bash
  2. # Slackware build script for octave
  3. # Copyright 2012-2022 Kyle Guinn <elyk03@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=octave
  24. VERSION=${VERSION:-7.1.0}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$(uname -m)" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$(uname -m) ;;
  33. esac
  34. fi
  35. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  36. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  37. exit 0
  38. fi
  39. TMP=${TMP:-/tmp/SBo}
  40. PKG=$TMP/package-$PRGNAM-$VERSION
  41. OUTPUT=${OUTPUT:-/tmp}
  42. DOCS="AUTHORS BUGS CITATION COPYING ChangeLog INSTALL* NEWS README"
  43. if [ "$ARCH" = "i586" ]; then
  44. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  45. LIBDIRSUFFIX=""
  46. elif [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. # Use GraphicsMagick by default. Fall back on ImageMagick from the full
  60. # Slackware install if it's not present.
  61. #
  62. # GraphicsMagick is default due to the fact that the Octave devs mainly test
  63. # with that, and went several releases before noticing ImageMagick was broken.
  64. # If ImageMagick doesn't work, install GraphicsMagick, or set MAGICK="".
  65. #
  66. # TODO: ImageMagick may no longer be compatible. The --with-magick argument
  67. # should be the name of a pkg-config file. Documentation suggests
  68. # "ImageMagick++" which does not exist. "ImageMagick" and "Magick++" exist;
  69. # the former does not pass configure checks, the latter fails at compile time.
  70. MAGICK=${MAGICK-GraphicsMagick++}
  71. if [ -n "$MAGICK" ] && ! pkg-config --exists $MAGICK; then
  72. MAGICK=ImageMagick
  73. fi
  74. if [ -n "$MAGICK" ]; then
  75. MAGICK="--with-magick=$MAGICK"
  76. fi
  77. set -e
  78. rm -rf $PKG
  79. mkdir -p $TMP $PKG $OUTPUT
  80. cd $TMP
  81. rm -rf $PRGNAM-$VERSION
  82. tar xvf $CWD/$PRGNAM-$VERSION.tar.lz
  83. cd $PRGNAM-$VERSION
  84. chown -R root:root .
  85. chmod -R u+w,go-w,a+rX-st .
  86. patch -p1 < $CWD/patches/3c3abe6dbe58.diff # https://savannah.gnu.org/bugs/?62295
  87. patch -p1 < $CWD/patches/atlas-lib-rename.diff
  88. autoreconf -vif
  89. # Avoid rebuilding the documentation by making stamp-vti newer than its
  90. # dependencies (in particular ./configure, which we may need to patch).
  91. # If you live far enough east or west that the date contained in version.texi
  92. # does not match that file's timestamp when printed accounting for your
  93. # timezone, then the docs get rebuilt with your local date.
  94. find . -name stamp-vti -exec touch {} +
  95. # TODO: Re-enable --with-openssl=auto in a future release once
  96. # https://savannah.gnu.org/bugs/?62416 is fixed.
  97. ./configure \
  98. --prefix=/usr \
  99. --libdir=\${prefix}/lib${LIBDIRSUFFIX} \
  100. --sysconfdir=/etc \
  101. --localstatedir=/var \
  102. --mandir=\${prefix}/man \
  103. --infodir=\${prefix}/info \
  104. --docdir=\${prefix}/doc/$PRGNAM-$VERSION \
  105. --disable-dependency-tracking \
  106. --with-linux-crypto \
  107. ${MAGICK} \
  108. --build=$ARCH-slackware-linux \
  109. CFLAGS="$SLKCFLAGS" \
  110. CXXFLAGS="$SLKCFLAGS" \
  111. FFLAGS="$SLKCFLAGS" \
  112. make
  113. # TODO: May fail if not all optional deps are installed (gl2ps in particular).
  114. #make check
  115. make install-strip DESTDIR=$PKG
  116. find $PKG/usr/lib${LIBDIRSUFFIX} -name '*.la' -delete
  117. find $PKG/usr/man -type f -exec gzip -9 {} +
  118. rm -f $PKG/usr/info/dir
  119. gzip -9 $PKG/usr/info/*.info*
  120. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  121. cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
  122. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  123. mkdir -p $PKG/install
  124. cat $CWD/slack-desc > $PKG/install/slack-desc
  125. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  126. cd $PKG
  127. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE