genometools.SlackBuild 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130
  1. #!/bin/bash
  2. # Slackware build script for genometools
  3. # Copyright 2014-2021 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=genometools
  24. VERSION=${VERSION:-1.6.1}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. BUILDARCH="32bit=yes"
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. BUILDARCH="32bit=yes"
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. BUILDARCH=""
  57. else
  58. SLKCFLAGS="-O2"
  59. LIBDIRSUFFIX=""
  60. fi
  61. set -e
  62. rm -rf $PKG
  63. mkdir -p $TMP $PKG $OUTPUT
  64. cd $TMP
  65. rm -rf $PRGNAM-$VERSION
  66. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  67. cd $PRGNAM-$VERSION
  68. chown -R root:root .
  69. # This is a looping symlink that the 'find' step below complains about.
  70. # The only thing that is used from this location is 'sam.h', so let's
  71. # just make a proper folder and copy it there.
  72. rm src/external/samtools-0.1.18/samtools
  73. mkdir -p src/external/samtools-0.1.18/samtools
  74. cp src/external/samtools-0.1.18/sam.h src/external/samtools-0.1.18/samtools
  75. find -L . \
  76. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  77. -o -perm 511 \) -exec chmod 755 {} \; -o \
  78. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  79. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  80. # Thanks Debian for the patch
  81. patch -p1 -i $CWD/gcc10.patch
  82. # Fix library and man pages path
  83. sed -i "s:lib/libgenometools:lib${LIBDIRSUFFIX}/libgenometools:g" Makefile
  84. sed -i "s:\$(prefix)/lib:\$(prefix)/lib${LIBDIRSUFFIX}:g" Makefile
  85. sed -i "s:/share/man/:/man/:g" Makefile
  86. CFLAGS="$SLKCFLAGS -Wno-error=format-truncation=" \
  87. CXXFLAGS="$SLKCFLAGS" \
  88. make $BUILDARCH \
  89. prefix=/usr
  90. make $BUILDARCH \
  91. prefix=$PKG/usr \
  92. install
  93. # Install python scripts
  94. cd gtpython
  95. python setup.py install --root=$PKG
  96. cd ..
  97. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  98. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  99. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  100. cp -a \
  101. CHANGELOG CONTRIBUTORS INSTALL LICENSE README VERSION www/* \
  102. $PKG/usr/doc/$PRGNAM-$VERSION
  103. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  104. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  105. mkdir -p $PKG/install
  106. cat $CWD/slack-desc > $PKG/install/slack-desc
  107. cd $PKG
  108. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE