engauge.SlackBuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128
  1. #!/bin/bash
  2. # Slackware build script for engauge
  3. # written by <pedro@gepasi.org>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=engauge
  24. VERSION=${VERSION:-12.1}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. PRGNAMFILE=$PRGNAM\-digitizer
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $PRGNAMFILE-$VERSION
  64. tar xvf $CWD/$PRGNAMFILE-$VERSION.tar.gz
  65. cd $PRGNAMFILE-$VERSION
  66. chown -R root:root .
  67. find -L . \
  68. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  69. -o -perm 511 \) -exec chmod 755 {} \; -o \
  70. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  71. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  72. POPPLER_INCLUDE=/usr/include/poppler/qt5 \
  73. POPPLER_LIB=/usr/lib${LIBDIRSUFFIX} \
  74. OPENJPEG_INCLUDE=/usr/include/openjpeg-2.4 \
  75. OPENJPEG_LIB=/usr/lib${LIBDIRSUFFIX} \
  76. qmake-qt5 \
  77. QMAKE_CFLAGS+="$SLKCFLAGS" \
  78. QMAKE_CXXFLAGS+="$SLKCFLAGS" \
  79. "CONFIG+=pdf jpeg2000" \
  80. DEFINES+=HELPDIR=/usr/doc/engauge \
  81. engauge.pro
  82. make
  83. # the package does not have a make install so we'll move things around
  84. strip --strip-unneeded bin/$PRGNAM 2>/dev/null || true
  85. # make the help file
  86. cd help
  87. ./build.bash
  88. cd ..
  89. mkdir -p $PKG/usr/bin
  90. cp -a bin/engauge $PKG/usr/bin
  91. mkdir -p $PKG/usr/share/$PRGNAM
  92. cp -ra samples $PKG/usr/share/$PRGNAM
  93. # make an icon from the supplied .ico file
  94. mkdir -p $PKG/usr/share/pixmaps
  95. convert src/img/digitizer.ico engauge.png
  96. cp -a engauge-0.png $PKG/usr/share/pixmaps/engauge.png
  97. mkdir -p $PKG/usr/share/applications
  98. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
  99. mkdir -p $PKG/usr/doc/$PRGNAM
  100. cp -ar INSTALL LICENSE README.md $PKG/usr/doc/$PRGNAM
  101. cp -ar bin/documentation/engauge.q* $PKG/usr/doc/$PRGNAM
  102. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM/$PRGNAM.SlackBuild
  103. find $PKG/usr/doc -type f -exec chmod 0644 {} \;
  104. mkdir -p $PKG/install
  105. cat $CWD/slack-desc > $PKG/install/slack-desc
  106. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  107. cd $PKG
  108. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE