boinc.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150
  1. #!/bin/bash
  2. # Slackware build script for boinc
  3. # Copyright 2013-2022 Edward Koenig, Vancouver, WA, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. #
  23. # 01MAY2022:
  24. # Version update
  25. # Removed need for STATIC wxWidgets-3.0 to avoid conflicts.
  26. # Bypass wxconfig symlink for compatibility.
  27. cd $(dirname $0) ; CWD=$(pwd)
  28. PRGNAM=boinc
  29. VERSION=${VERSION:-7.18.1}
  30. BRANCH=${BRANCH:-7.18}
  31. BUILD=${BUILD:-2}
  32. TAG=${TAG:-_SBo}
  33. PKGTYPE=${PKGTYPE:-tgz}
  34. if [ -z "$ARCH" ]; then
  35. case "$( uname -m )" in
  36. i?86) ARCH=i586 ;;
  37. arm*) ARCH=arm ;;
  38. *) ARCH=$( uname -m ) ;;
  39. esac
  40. fi
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. if [ "$ARCH" = "i586" ]; then
  49. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "i686" ]; then
  52. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  53. LIBDIRSUFFIX=""
  54. elif [ "$ARCH" = "x86_64" ]; then
  55. SLKCFLAGS="-O2 -fPIC"
  56. LIBDIRSUFFIX="64"
  57. else
  58. SLKCFLAGS="-O2"
  59. LIBDIRSUFFIX=""
  60. fi
  61. set -e
  62. # Your default working directory location. Pass with DATADIR=<dir> Boinc.SlackBuild
  63. DATADIR=${DATADIR:-'$HOME/.boinc_data'}
  64. BOINCMGR=${BOINCMGR:-yes}
  65. if [ "$BOINCMGR" = "yes" ]; then
  66. do_mgr="--enable-manager"
  67. else
  68. do_mgr="--disable-manager --enable-client"
  69. fi
  70. rm -rf $PKG
  71. mkdir -p $TMP $PKG $OUTPUT
  72. cd $TMP
  73. rm -rf $PRGNAM-client_release-$BRANCH-$VERSION
  74. tar xvf $CWD/$PRGNAM-client_release-$BRANCH-$VERSION.tar.gz
  75. cd $PRGNAM-client_release-$BRANCH-$VERSION
  76. chown -R root:root .
  77. find -L . \
  78. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  79. -o -perm 511 \) -exec chmod 755 {} \; -o \
  80. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  81. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  82. ./_autosetup
  83. CFLAGS="$SLKCFLAGS" \
  84. CXXFLAGS="$SLKCFLAGS" \
  85. ./configure \
  86. --prefix=/usr \
  87. --libdir=/usr/lib${LIBDIRSUFFIX} \
  88. --sysconfdir=/etc \
  89. --localstatedir=/var \
  90. --mandir=/usr/man \
  91. --docdir=/usr/doc/$PRGNAM-$VERSION \
  92. --disable-server \
  93. --disable-shared \
  94. $do_mgr \
  95. --with-x \
  96. --with-wx-config=/usr/lib$LIBDIRSUFFIX/wx/config/gtk3-unicode-3.0 \
  97. --build=$ARCH-slackware-linux
  98. make
  99. make install DESTDIR=$PKG
  100. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  101. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  102. find $PKG/usr/man -type f -exec gzip -9 {} \;
  103. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  104. cat $CWD/boincgui.sh > $PKG/usr/bin/boincgui.sh
  105. sed -i "s|WORKDIR|$DATADIR|g" $PKG/usr/bin/boincgui.sh
  106. chmod +x $PKG/usr/bin/boincgui.sh
  107. mkdir -p $PKG/etc/rc.d
  108. cat $CWD/rc.boinc.txt > $PKG/etc/rc.d/rc.boinc.new
  109. mkdir -p $PKG/usr/share/{applications,pixmaps}
  110. cp $CWD/boinc.desktop $PKG/usr/share/applications
  111. cp $CWD/boinc.png $PKG/usr/share/pixmaps
  112. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  113. cp -a COPYING COPYING.LESSER COPYRIGHT INSTALL notes $PKG/usr/doc/$PRGNAM-$VERSION
  114. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  115. rm -f $PKG/usr/lib*/*.la
  116. # remove unneeded init script, systemd service
  117. rm -rf $PKG/etc/default
  118. rm -rf $PKG/etc/init.d
  119. rm -rf $PKG/usr/lib
  120. rm -f $PKG/usr/bin/boinc_client
  121. mkdir -p $PKG/install
  122. cat $CWD/slack-desc > $PKG/install/slack-desc
  123. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  124. cd $PKG
  125. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE