Gridcoin-Research.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. #!/bin/bash
  2. # Slackware build script for Gridcoin-Research
  3. # Copyright 2018-2021 Edward W. Koenig, Vancouver, WA, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=Gridcoin-Research
  24. VERSION=${VERSION:-5.3.3.0}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $PRGNAM-$VERSION
  63. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  64. cd $PRGNAM-$VERSION
  65. chown -R root:root .
  66. find -L . \
  67. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  68. -o -perm 511 \) -exec chmod 755 {} \; -o \
  69. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  70. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  71. if [ "${QRENC:-yes}" = "yes" ]; then
  72. useqr="--with-qrencode"
  73. else
  74. useqr="--without-qrencode"
  75. fi
  76. if [ "${UPNP:-no}" = "yes" ]; then
  77. usepnp="--with-miniupnpc"
  78. else
  79. usepnp="--without-miniupnpc"
  80. fi
  81. ./autogen.sh
  82. CFLAGS="$SLKCFLAGS" \
  83. CXXFLAGS="$SLKCFLAGS" \
  84. ./configure \
  85. --prefix=/usr \
  86. --libdir=/usr/lib${LIBDIRSUFFIX} \
  87. --sysconfdir=/etc \
  88. --localstatedir=/var \
  89. --mandir=/usr/man \
  90. --docdir=/usr/doc/$PRGNAM-$VERSION \
  91. --with-gui=yes \
  92. $useqr \
  93. $usepnp \
  94. --build=$ARCH-slackware-linux
  95. make
  96. make install DESTDIR=$PKG
  97. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  98. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  99. # get the man pages
  100. install -D -m 644 $TMP/$PRGNAM-$VERSION/doc/gridcoinresearch.1 $PKG/usr/man/man1/gridcoinresearch.1
  101. install -D -m 644 $TMP/$PRGNAM-$VERSION/doc/gridcoinresearchd.1 $PKG/usr/man/man1/gridcoinresearchd.1
  102. find $PKG/usr/man -type f -exec gzip -9 {} \;
  103. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  104. # Add default configuration
  105. mkdir -p $PKG/etc/$PRGNAM
  106. cp -a $CWD/gridcoinresearch.conf $PKG/etc/$PRGNAM
  107. mkdir -p $PKG/usr/share/pixmaps $PKG/usr/share/applications
  108. cp -a $TMP/$PRGNAM-$VERSION/share/pixmaps/* $PKG/usr/share/pixmaps
  109. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/doc
  110. cp -a \
  111. COPYING CHANGELOG.md README.md SECURITY.md CONTRIBUTING.md \
  112. $PKG/usr/doc/$PRGNAM-$VERSION
  113. cp -a doc/* $PKG/usr/doc/$PRGNAM-$VERSION/doc
  114. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  115. # we can delete the redundant man pages
  116. rm -f $PKG/usr/doc/$PRGNAM-$VERSION/gridcoinresearch.*
  117. rm -f $PKG/usr/doc/$PRGNAM-$VERSION/gridcoinresearchd.*
  118. mkdir -p $PKG/install
  119. cat $CWD/slack-desc > $PKG/install/slack-desc
  120. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  121. cd $PKG
  122. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE