Ted.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138
  1. #!/bin/bash
  2. # Slackware build script for Ted
  3. # Copyright 2019 GOSIKI Agiri <agiri@cocaine.ninja>.
  4. # Previously written by Willy Sudiarto Raharjo <willysr@slackbuilds.org>.
  5. # Originally written by Hannes Worst <hannesworst@gmail.com>.
  6. # All right reserved
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=Ted
  26. VERSION=${VERSION:-2.23}
  27. BUILD=${BUILD:-2}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. SRCNAM=$(echo $PRGNAM | tr T t)
  48. if [ "$ARCH" = "i586" ]; then
  49. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. MARCH=i386
  52. elif [ "$ARCH" = "i686" ]; then
  53. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  54. LIBDIRSUFFIX=""
  55. MARCH=i386
  56. elif [ "$ARCH" = "x86_64" ]; then
  57. SLKCFLAGS="-O2 -fPIC"
  58. LIBDIRSUFFIX="64"
  59. MARCH=amd64
  60. fi
  61. set -e
  62. rm -rf $PKG
  63. mkdir -p $TMP $PKG $OUTPUT
  64. cd $TMP
  65. rm -rf $PRGNAM-$VERSION
  66. tar xvf $CWD/$SRCNAM-$VERSION.src.tar.gz
  67. cd $PRGNAM-$VERSION
  68. chown -R root:root .
  69. find -L . \
  70. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  71. -o -perm 511 \) -exec chmod 755 {} \; -o \
  72. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  73. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  74. # Set the right ARCH
  75. sed \
  76. -e "/^M_MACHINE/s|=.*|=$ARCH|" \
  77. -e "/^M_ARCH/s|=.*|=$ARCH|" \
  78. -i tedPackage/configure
  79. # select appropriate widget set
  80. WIDGET=${WIDGET:-gtk}
  81. case $WIDGET in
  82. gtk) widgetopt=GTK;;
  83. motif) widgetopt=MOTIF;;
  84. *) echo "Wrong widget set selected, choose gtk or motif only!"; exit 1;;
  85. esac
  86. CFLAGS="$SLKCFLAGS" \
  87. CXXFLAGS="$SLKCFLAGS" \
  88. make -j1 CONFIGURE_OPTIONS="--with-$widgetopt"
  89. make -j1 package
  90. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  91. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  92. # Extract the created package by make package
  93. tar -xvf $TMP/$PRGNAM-$VERSION/${SRCNAM}Package/$SRCNAM-$VERSION-linux-$MARCH.tar.gz -C $PKG/
  94. mkdir -p $PKG/usr/man/man1/
  95. mv $PKG/usr/share/Ted/doc/*.1 $PKG/usr/man/man1/
  96. rm -rf $PKG/usr/share/Ted/doc/
  97. find $PKG/usr/man -type f -exec gzip -9 {} \;
  98. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  99. # This one is already in .gz format
  100. mv $PKG/usr/share/man/man1/Ted.1.gz $PKG/usr/man/man1/
  101. rm -rf $PKG/usr/share/man/
  102. # a couple of useful scripts to fix and convert documents
  103. for F in `ls $PKG/usr/share/Ted/examples/`
  104. do
  105. mv $PKG/usr/share/Ted/examples/$F $PKG/usr/bin/$(basename -s .sh $F)
  106. done
  107. rm -rf $PKG/usr/share/Ted/examples
  108. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  109. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  110. mv $PKG/usr/share/Ted/config/ $PKG/usr/doc/$PRGNAM-$VERSION/
  111. mkdir -p $PKG/install
  112. cat $CWD/slack-desc > $PKG/install/slack-desc
  113. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  114. cd $PKG
  115. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE