spamassassin.SlackBuild 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. #!/bin/bash
  2. # Slackware build script for spamassassin
  3. # Copyright 2008-2015 LukenShiro, Italy
  4. # All rights reserved.
  5. #
  6. # Maintained by Gerardo Zamudio <gerardo.zamudio@linux.com>
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. # Thanks to Nishant Limbachia for providing a SQL script to be used with
  25. # spamassassin database, and most of spamassassin dependencies' scripts.
  26. cd $(dirname $0) ; CWD=$(pwd)
  27. PRGNAM=spamassassin
  28. VERSION=${VERSION:-3.4.6}
  29. BUILD=${BUILD:-1}
  30. TAG=${TAG:-_SBo}
  31. PKGTYPE=${PKGTYPE:-tgz}
  32. if [ -z "$ARCH" ]; then
  33. case "$( uname -m )" in
  34. i?86) ARCH=i486 ;;
  35. arm*) ARCH=arm ;;
  36. *) ARCH=$( uname -m ) ;;
  37. esac
  38. fi
  39. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  40. # the name of the created package would be, and then exit. This information
  41. # could be useful to other scripts.
  42. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  43. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  44. exit 0
  45. fi
  46. TMP=${TMP:-/tmp/SBo}
  47. PKG=$TMP/package-$PRGNAM
  48. OUTPUT=${OUTPUT:-/tmp}
  49. SRC_PRGNAM=Mail-SpamAssassin
  50. DOCFILES="Changes CREDITS INSTALL LICENSE NOTICE PACKAGING procmailrc.example \
  51. README sample-nonspam.txt sample-spam.txt TRADEMARK UPGRADE USAGE sql/"
  52. if [ "$ARCH" = "i486" ]; then
  53. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  54. elif [ "$ARCH" = "i686" ]; then
  55. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  56. elif [ "$ARCH" = "x86_64" ]; then
  57. SLKCFLAGS="-O2 -fPIC"
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $SRC_PRGNAM-$VERSION
  64. tar xvf $CWD/$SRC_PRGNAM-$VERSION.tar.bz2
  65. cd $SRC_PRGNAM-$VERSION
  66. chown -R root:root .
  67. find -L . \
  68. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  69. -o -perm 511 \) -exec chmod 755 {} \; -o \
  70. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  71. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  72. PERL_MM_USE_DEFAULT=1 \
  73. perl Makefile.PL \
  74. PREFIX=/usr \
  75. INSTALLDIRS=vendor \
  76. INSTALLVENDORMAN1DIR=/usr/man/man1 \
  77. INSTALLVENDORMAN3DIR=/usr/man/man3
  78. make CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS"
  79. make install DESTDIR=$PKG
  80. find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
  81. # Remove empty directories
  82. find $PKG -depth -type d -empty -delete || true
  83. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  84. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  85. find $PKG/usr/man -type f -exec gzip -9 {} \;
  86. for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  87. # Preserve config files
  88. ( cd $PKG/etc/mail/spamassassin
  89. mv init.pre init.pre.new
  90. mv local.cf local.cf.new
  91. mv v310.pre v310.pre.new
  92. mv v312.pre v312.pre.new
  93. mv v320.pre v320.pre.new
  94. mv v330.pre v330.pre.new
  95. mv v340.pre v340.pre.new
  96. )
  97. # Copy init script to /etc/rc.d and modify it for name consistency
  98. mkdir -p $PKG/etc/rc.d/
  99. install -m 0755 spamd/slackware-rc-script.sh $PKG/etc/rc.d/rc.spamd.new
  100. sed -i "s#SNAME=rc.spamassassin#SNAME=rc.spamd#g" $PKG/etc/rc.d/rc.spamd.new
  101. # Create file for enabling rc.spamd's start
  102. cat > $PKG/etc/spamassassin.conf.new << EOF
  103. ENABLED=1
  104. EOF
  105. # Copy cron script
  106. mkdir -p $PKG/etc/cron.weekly/
  107. install -m 0755 $CWD/sa-update.sh $PKG/etc/cron.weekly/
  108. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  109. cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
  110. cat $CWD/spamassassin-db.sql > $PKG/usr/doc/$PRGNAM-$VERSION/spamassassin-db.sql
  111. cat $CWD/README.SLACKWARE > $PKG/usr/doc/$PRGNAM-$VERSION/README.SLACKWARE
  112. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  113. mkdir -p $PKG/install
  114. cat $CWD/slack-desc > $PKG/install/slack-desc
  115. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  116. cd $PKG
  117. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE