opera-developer.SlackBuild 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. #!/bin/bash
  2. #
  3. # Slackware build script for opera-developer.
  4. #
  5. # Copyright 2016-2022 Edinaldo P. Silva, Rio de Janeiro, Brazil.
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=opera-developer
  26. VERSION=${VERSION:-88.0.4395.0}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. set -e
  48. if [ "$ARCH" = "i586" ]; then
  49. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. BITS="i386"
  52. echo "This package is currently only available for 64bit."
  53. exit 1
  54. elif [ "$ARCH" = "i686" ]; then
  55. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  56. LIBDIRSUFFIX=""
  57. BITS="i386"
  58. echo "This package is currently only available for 64bit."
  59. exit 1
  60. elif [ "$ARCH" = "x86_64" ]; then
  61. SLKCFLAGS="-O2 -fPIC"
  62. LIBDIRSUFFIX="64"
  63. BITS="amd64"
  64. else
  65. echo "Package for $(uname -m) architecture is not available."
  66. exit 1
  67. fi
  68. rm -rf $PKG
  69. mkdir -p $TMP $PKG $OUTPUT
  70. cd $TMP
  71. rm -rf $PRGNAM-${VERSION}
  72. mkdir -p $PRGNAM-${VERSION}
  73. ar p $CWD/${PRGNAM}_${VERSION}_${BITS}.deb data.tar.xz | xz -d | tar -xvf- \
  74. --transform="s,/lib/.*-linux-gnu,/lib$LIBDIRSUFFIX," \
  75. --exclude="./usr/share/lintian" --exclude="./usr/share/menu" -C $PRGNAM-${VERSION}
  76. cd $PRGNAM-${VERSION}
  77. chown -R root:root .
  78. find -L . \
  79. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  80. -o -perm 511 \) -exec chmod 755 {} \; -o \
  81. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  82. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  83. mv usr $PKG
  84. mv $PKG/usr/share/doc $PKG/usr/
  85. mv $PKG/usr/doc/$PRGNAM $PKG/usr/doc/${PRGNAM}-$VERSION
  86. cd $PKG/usr/doc/${PRGNAM}-$VERSION/
  87. gzip -dc changelog.gz > ChangeLog; rm -f changelog.gz;
  88. install -Dm644 copyright $PKG/usr/share/licenses/$PRGNAM/copyright
  89. install -Dm644 $CWD/eula.html $PKG/usr/share/licenses/$PRGNAM/eula.html
  90. install -Dm644 $CWD/terms.html $PKG/usr/share/licenses/$PRGNAM/terms.html
  91. install -Dm644 $CWD/privacy.html $PKG/usr/share/licenses/$PRGNAM/privacy.html
  92. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  93. mkdir -p $PKG/install
  94. cat $CWD/slack-desc > $PKG/install/slack-desc
  95. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  96. cd $PKG
  97. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE