123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120 |
- #!/bin/bash
- # Slackware build script for stratagus
- # Written by B. Watson (yalhcru@gmail.com)
- # Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
- # Note to future maintainers (in case I get hit by a bus or something):
- # If you update this, you need to update wargus to the same version. If
- # you see a newer stratagus release but wargus hasn't yet been updated,
- # resist the temptation to update to the new stratagus until the wargus
- # devs have made a release with the same version number. Failure to do
- # this will cause breakage...
- # Build option notes:
- # - technically libmikmod is optional, but it's a small lib with no deps
- # of its own. Games might need it, better to make it a hard dep.
- # - fluidsynth is also technically optional, but the #1 use for
- # stratagus is to play wargus, which requires it.
- # - upx is disabled, it's only used for packing the stratagus executable,
- # which we don't do in SlackBuilds.
- # - touchscreen support is disabled. I have no hardware to test it on,
- # and generally Slackware isn't used on touchscreen devices. If you
- # want to play with it, add -DENABLE_TOUCHSCREEN=ON in the cmake
- # command below.
- # 20180915 bkw: updated for v2.4.1
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=stratagus
- VERSION=${VERSION:-2.4.1}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
- cd $PRGNAM-$VERSION
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- # -DDOCDIR isn't 100% respected, some of the docs end up in hardcoded
- # share/doc/$PRGNAM, so:
- sed -i "s,share/doc/$PRGNAM,doc/$PRGNAM-$VERSION," CMakeLists.txt
- # 20211119 bkw: fix compile with -current's gcc.
- sed -i 's,"_C_," _C_,' src/ai/ai_plan.cpp src/stratagus/script.cpp
- mkdir -p build
- cd build
- cmake \
- -DENABLE_DOC=ON \
- -DENABLE_DEV=ON \
- -DENABLE_STRIP=ON \
- -DBINDIR=/usr/games \
- -DGAMEDIR=/usr/games \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DMANDIR:PATH=man/man6 \
- -DDOCDIR:PATH=doc/$PRGNAM-$VERSION \
- -DCMAKE_BUILD_TYPE=Release ..
- make
- make install DESTDIR=$PKG
- cd ..
- # get rid of empty useless file
- rm -f $PKG/usr/include/*.nsi
- gzip -9 $PKG/usr/man/man6/$PRGNAM.6
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a README* COPYING $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|