123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114 |
- #!/bin/bash
- # Slackware build script for idesk
- # Written by B. Watson (yalhcru@gmail.com)
- # Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
- # Disclaimer:
- # idesk is old and unmaintained. I wrote this SlackBuild at the request
- # of someone on IRC, and decided "what the hell, I'll submit it". If
- # you're reading this because you want to change anything about it, you're
- # welcome to take over maintenance of this build (seriously, I don't use
- # idesk, beyond running it once and seeing that it worked). The only
- # maintenance I'll ever do for this build is to fix any build problems
- # on future versions of Slackware (unless upstream suddenly releases a
- # new version, but it's been a dead project for almost 10 years now).
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=idesk
- VERSION=${VERSION:-0.7.5}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
- cd $PRGNAM-$VERSION
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- # missing #include files, newer g++ cares more than the ones from 2005.
- patch -p1 < $CWD/compilefix.diff
- # The next two stanzas allow the program to start up without the user
- # having to create or edit any config files. It won't *do* much but at
- # least we can tell if it works or not. This seems like a minor deviation
- # from the Slackware way, but in reality it lets me automate my testing
- # so it ultimately increases the amount of slack in the universe.
- # don't abort if ~/.idesktop/ dir doesn't exist (just create it). Seriously,
- # that almost belongs on thedailywtf.
- patch -p1 < $CWD/create_user_dir.diff
- # don't reference /usr/local in default.lnk (which gets installed in
- # /usr/share/idesk as well as /usr/doc). Also use kdialog for the
- # "about" icon, as Slackware doesn't ship Xdialog.
- sed -i \
- -e 's,/usr/local,/usr,g' \
- -e 's,Xdialog,kdialog,g' \
- examples/*
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --build=$ARCH-slackware-linux
- make
- make install-strip DESTDIR=$PKG
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a AUTHORS COPYING ChangeLog NEWS README TODO examples $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|