scipy.SlackBuild 3.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. #!/bin/bash
  2. # Build script for the Python SciPy package
  3. # Copyright 2011-2018 Serban Udrea <s.udrea@gsi.de>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification,
  7. # is permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR
  13. # IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
  14. # WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
  15. # DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT,
  16. # INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
  17. # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
  18. # SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
  19. # HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
  20. # STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
  21. # IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
  22. # POSSIBILITY OF SUCH DAMAGE.
  23. # Written by Eugene Suter <easuter@gmail.com>
  24. # Updated to 0.7.2 by João Felipe Santos <joao.eel@gmail.com>
  25. # Updated up to 1.1.0 by Serban Udrea <S.Udrea@gsi.de>
  26. # Added support for building with debugging symbols (S. Udrea)
  27. cd $(dirname $0) ; CWD=$(pwd)
  28. PRGNAM=scipy
  29. VERSION=${VERSION:-1.2.2}
  30. BUILD=${BUILD:-2}
  31. TAG=${TAG:-_SBo}
  32. PKGTYPE=${PKGTYPE:-tgz}
  33. if [ -z "$ARCH" ]; then
  34. case "$( uname -m )" in
  35. i?86) ARCH=i586 ;;
  36. arm*) ARCH=arm ;;
  37. *) ARCH=$( uname -m ) ;;
  38. esac
  39. fi
  40. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  41. # the name of the created package would be, and then exit. This information
  42. # could be useful to other scripts.
  43. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  44. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  45. exit 0
  46. fi
  47. TMP=${TMP:-/tmp/SBo}
  48. PKG=${PKG:-$TMP/package-$PRGNAM}
  49. OUTPUT=${OUTPUT:-/tmp}
  50. set -e
  51. rm -rf $PKG
  52. mkdir -p $TMP $PKG $OUTPUT
  53. cd $TMP
  54. rm -rf "$PRGNAM-$VERSION"
  55. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  56. cd "$PRGNAM-$VERSION"
  57. chown -R root:root .
  58. find -L . \
  59. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  60. -exec chmod 755 {} \; -o \
  61. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  62. -exec chmod 644 {} \;
  63. export FFLAGS="-fallow-argument-mismatch -fPIC"
  64. DEBUG=${DEBUG:-no}
  65. DEBUG=$(echo "$DEBUG"|cut -b 1|tr a-z A-Z)
  66. if [ "$DEBUG" = "N" ]
  67. then
  68. python setup.py install --root $PKG
  69. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  70. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  71. else
  72. python setup.py build --debug
  73. python setup.py install --root $PKG
  74. fi
  75. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  76. cp -a LICENSE.txt THANKS.txt INSTALL.rst.txt HACKING.rst.txt PKG-INFO \
  77. $PKG/usr/doc/$PRGNAM-$VERSION
  78. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  79. find $PKG/usr/doc -type f -exec chmod 0644 {} \;
  80. mkdir -p $PKG/install
  81. cat $CWD/slack-desc > $PKG/install/slack-desc
  82. cd $PKG
  83. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE