kodi.SlackBuild 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161
  1. #!/bin/bash
  2. # Slackware build script for kodi
  3. # Copyright 2009-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=kodi
  24. SRCNAM=xbmc
  25. CODNAM=Matrix
  26. VERSION=${VERSION:-19.4}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. rm -rf $PKG
  62. mkdir -p $TMP $PKG $OUTPUT
  63. cd $TMP
  64. rm -rf $SRCNAM-$VERSION-$CODNAM $PRGNAM-build
  65. tar xvf $CWD/$SRCNAM-$VERSION-$CODNAM.tar.gz
  66. cd $SRCNAM-$VERSION-$CODNAM
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. # Autodetection of "optional" dependencies sucks. It does not work and
  74. # compilation will fail on each of these if not explicitly disabled.
  75. # Figured I'd mplemented my own autodetection instead of requiring
  76. # passing a bunch of annoying flags :)
  77. if pkg-config --exists avahi-core ; then AVAHI=ON; else AVAHI=OFF; fi
  78. if pkg-config --exists cwiid ; then CWIID=ON; else CWIID=OFF; fi
  79. if pkg-config --exists dav1d ; then DAV1D=ON; else DAV1D=OFF; fi
  80. if pkg-config --exists libmicrohttpd ; then WEBSERVER=ON; else WEBSERVER=OFF; fi
  81. if pkg-config --exists libcec ; then CEC=ON; else CEC=OFF; fi
  82. if pkg-config --exists libnfs ; then NFS=ON; else NFS=OFF; fi
  83. if pkg-config --exists lirc ; then LIRC=ON; else LIRC=OFF; fi
  84. if [ -f /usr/bin/shairplay ] ; then AIRPLAY=ON; else AIRPLAY=OFF; fi
  85. mkdir -p $TMP/$PRGNAM-build
  86. cd $TMP/$PRGNAM-build
  87. cmake \
  88. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  89. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  90. -DCMAKE_INSTALL_PREFIX=/usr \
  91. -DAPP_RENDER_SYSTEM=gl \
  92. -DCORE_PLATFORM_NAME="x11" \
  93. -DENABLE_INTERNAL_FSTRCMP=ON \
  94. -DENABLE_INTERNAL_UDFREAD=ON \
  95. -DENABLE_AIRTUNES=$AIRPLAY \
  96. -DENABLE_AVAHI=$AVAHI \
  97. -DENABLE_CEC=$CEC \
  98. -DENABLE_DAV1D=$DAV1D \
  99. -DENABLE_EVENTCLIENTS=$CWIID \
  100. -DENABLE_LIRCCLIENT=$LIRC \
  101. -DENABLE_MICROHTTPD=$WEBSERVER \
  102. -DENABLE_NFS=$NFS \
  103. -Dlibdvdcss_URL=$CWD/libdvdcss-1.4.2-Leia-Beta-5.tar.gz \
  104. -Dlibdvdnav_URL=$CWD/libdvdnav-6.0.0-Leia-Alpha-3.tar.gz \
  105. -Dlibdvdread_URL=$CWD/libdvdread-6.0.0-Leia-Alpha-3.tar.gz \
  106. -DCROSSGUID_URL=$CWD/crossguid-8f399e8bd4.tar.gz \
  107. -DFSTRCMP_URL=$CWD/fstrcmp-0.7.D001.tar.gz \
  108. -DUDFREAD_URL=$CWD/libudfread-1.1.0.tar.gz \
  109. -DCMAKE_BUILD_TYPE=Release ../$SRCNAM-$VERSION-$CODNAM
  110. make
  111. make install/strip DESTDIR=$PKG
  112. cd ..
  113. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  114. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  115. # Install manpages
  116. mkdir -p $PKG/usr/man/man1
  117. for i in {$PRGNAM{,.bin,-standalone},TexturePacker}.1; do
  118. install -m 0644 $SRCNAM-$VERSION-$CODNAM/docs/manpages/$i $PKG/usr/man/man1/$i
  119. done
  120. # Install Event Control manpages if enabled
  121. if [ $CWIID == "ON" ]; then
  122. for i in $PRGNAM{-ps3remote,-wiiremote,-send}.1; do
  123. install -m 0644 $SRCNAM-$VERSION-$CODNAM/docs/manpages/$i $PKG/usr/man/man1/$i
  124. done
  125. fi
  126. find $PKG/usr/man -type f -exec gzip -9 {} \;
  127. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  128. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  129. (
  130. cd $SRCNAM-$VERSION-$CODNAM
  131. cp -a README.md privacy-policy.txt version.txt docs/MANIFESTO.md $PKG/usr/doc/$PRGNAM-$VERSION
  132. if [ $CWIID == "ON" ]; then
  133. cat tools/EventClients/README.txt > $PKG/usr/doc/$PRGNAM-$VERSION/Event-Client-README.txt
  134. fi
  135. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  136. )
  137. mkdir -p $PKG/install
  138. cat $CWD/slack-desc > $PKG/install/slack-desc
  139. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  140. cd $PKG
  141. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE