123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124 |
- #!/bin/bash
- # Slackware build script for qiv
- # Written by Pablo Santamaria (email removed)
- # Modified & now maintained by B. Watson <yalhcru@gmail.com>. Original
- # version had no license, modified version released under the WTFPL. See
- # http://www.wtfpl.net/txt/copying/ for details.
- # 20191231 bkw:
- # - Add libopenraw (raw camera image) formats, BUILD=2.
- # - Remove mention of wmf-pixbuf loader from README and .sqf
- # since there's a Slackware update that removes the need for it.
- # 20191226 bkw:
- # - Upgrade for v2.3.2. This was released a month after my last update,
- # but the download page on the site doesn't link to it (found it just
- # now by editing the URL for v2.3.1), so my update-checker script
- # never saw it...
- # - As compensation for my tardiness, add support for a bunch of new
- # image types.
- # 20170209 bkw:
- # - Take over maintenance
- # - i486 => i586
- # - Add latest fixes from upstream's git
- # - Get rid of redundant stripping of binaries and gzipping
- # of man pages (upstream's 'make install' already does it)
- # - Don't install README.INSTALL
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=qiv
- VERSION=${VERSION:-2.3.2}
- BUILD=${BUILD:-2}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- tar xvf $CWD/$PRGNAM-$VERSION.tgz
- cd $PRGNAM-$VERSION
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- # Patch to add potential support for various image formats. This patch
- # doesn't actually contain any code for decoding/displaying new image
- # formats. All it does is add file extensions and magic to the list
- # of filetypes qiv will attempt to display via imlib and/or pixbuf.
- # It's up to imlib/pixbuf to actually support the image types. Some of
- # these are already supported in Slackware, a few require optional deps
- # (see README).
- # For the optional ones (e.g. webp), this patch doesn't do any harm
- # if the support library's not installed. All it does is make qiv warn
- # "Unable to read file" on stderr, instead of silently skipping it.
- patch -p1 < $CWD/new_formats.diff
- # Three sed expressions here. In order:
- # 1. Make qiv build with our compiler flags.
- # 2. Disable the test, since it requires X to be running and
- # accepting connections from root.
- # 3. Put man page where Slackware likes them.
- sed -i -e "s/-O2 -Wall/$SLKCFLAGS/" \
- -e "s|\./qiv|echo &|" \
- -e 's,/share/man,/man,g' \
- Makefile
- make
- make install PREFIX=$PKG/usr
- # binary already stripped, man pages already gzipped
- rm -f README.INSTALL # don't need this in a binary package
- chmod 644 contrib/* # docs shouldn't be executable even if they're scripts
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a Changelog README* intro.jpg contrib/ $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|