setedit.SlackBuild 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116
  1. #!/bin/bash
  2. # Slackware build script for <setedit>
  3. # Copyright 2019, Zhu Qun-Ying
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=setedit
  24. VERSION=${VERSION:-0.5.8p}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. GIT_COMMIT_VER=d8231bc28ced01aba8236deb4610871dd86c5b9b
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $PRGNAM-$GIT_COMMIT_VER
  64. if [ -e $CWD/$PRGNAM-$VERSION.tar.bz2 ] ; then
  65. tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
  66. else
  67. tar xvf $CWD/$PRGNAM-$GIT_COMMIT_VER.tar.bz2
  68. fi
  69. cd $PRGNAM-$GIT_COMMIT_VER/$PRGNAM
  70. if [ "$ARCH" = "x86_64" ]; then
  71. sed -i -s 's/\/lib\>/\/lib64/g' config.pl makes/linux/compress.pl
  72. fi
  73. CFLAGS="$SLKCFLAGS" \
  74. CXXFLAGS="$SLKCFLAGS" \
  75. ./configure \
  76. --prefix=/usr
  77. make -j1
  78. make -j1 install prefix=$PKG/usr
  79. strip $PKG/usr/bin/*
  80. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM/$PRGNAM.SlackBuild
  81. mkdir -p $PKG/usr/man/man1
  82. if [ "$ARCH" = "x86_64" ]; then
  83. mkdir -p $PKG/usr/lib64/setedit
  84. cp ./makes/linux/setedit-0.5.8/lib64/setedit/* $PKG/usr/lib64/setedit
  85. fi
  86. cat doc/infview.man | gzip -9 > $PKG/usr/man/man1/infview.1.gz
  87. cat doc/setedit.man | gzip -9 > $PKG/usr/man/man1/setedit.1.gz
  88. mkdir -p $PKG/etc/profile.d
  89. if [ "$ARCH" = "x86_64" ]; then
  90. sed -s 's/\/lib/\/lib64/g' $CWD/setedit.csh > $PKG/etc/profile.d/setedit.csh
  91. sed -s 's/\/lib/\/lib64/g' $CWD/setedit.sh > $PKG/etc/profile.d/setedit.sh
  92. else
  93. cp $CWD/setedit.*sh $PKG/etc/profile.d
  94. fi
  95. mkdir -p $PKG/install
  96. cat $CWD/slack-desc > $PKG/install/slack-desc
  97. cd $PKG
  98. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE