ragel.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126
  1. #!/bin/bash
  2. # Slackware build script for ragel
  3. # Copyright 2012-2019 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # 20220308 bkw: Modified by SlackBuilds.org:
  23. # This build always fails if ragel is already installed. Add a check
  24. # to make it fail quickly, with a useful error message (instead of a
  25. # confusing link error, after compiling for several minutes).
  26. cd $(dirname $0) ; CWD=$(pwd)
  27. PRGNAM=ragel
  28. VERSION=${VERSION:-7.0.0.12}
  29. BUILD=${BUILD:-2}
  30. TAG=${TAG:-_SBo}
  31. PKGTYPE=${PKGTYPE:-tgz}
  32. if [ -z "$ARCH" ]; then
  33. case "$( uname -m )" in
  34. i?86) ARCH=i586 ;;
  35. arm*) ARCH=arm ;;
  36. *) ARCH=$( uname -m ) ;;
  37. esac
  38. fi
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. DOCS="AUTHORS COPYING README TODO"
  60. set -e
  61. if [ -x /usr/bin/ragel ]; then
  62. cat <<EOF
  63. ****************************************************************
  64. This build would fail, because you already have ragel installed.
  65. Do this first:
  66. removepkg ragel
  67. ...then run this script again. Sorry.
  68. ****************************************************************
  69. EOF
  70. exit 1
  71. fi
  72. rm -rf $PKG
  73. mkdir -p $TMP $PKG $OUTPUT
  74. cd $TMP
  75. rm -rf $PRGNAM-$VERSION
  76. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  77. cd $PRGNAM-$VERSION
  78. chown -R root:root .
  79. find -L . \
  80. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  81. -o -perm 511 \) -exec chmod 755 {} \+ -o \
  82. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  83. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
  84. CFLAGS="$SLKCFLAGS" \
  85. CXXFLAGS="$SLKCFLAGS" \
  86. ./configure \
  87. --prefix=/usr \
  88. --libdir=/usr/lib${LIBDIRSUFFIX} \
  89. --sysconfdir=/etc \
  90. --localstatedir=/var \
  91. --mandir=/usr/man \
  92. --docdir=/usr/doc/$PRGNAM-$VERSION \
  93. --disable-static \
  94. --build=$ARCH-slackware-linux
  95. make
  96. make install-strip DESTDIR=$PKG
  97. gzip -9 $PKG/usr/man/man*/*
  98. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  99. cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
  100. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  101. rm -f $PKG/usr/lib*/*.la
  102. mkdir -p $PKG/install
  103. cat $CWD/slack-desc > $PKG/install/slack-desc
  104. cd $PKG
  105. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE