123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139 |
- #!/bin/bash
- # Slackware build script for nodejs
- # Thanks to Audrius Kažukauskas
- # Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
- # Willy Sudiarto Raharjo <willysr@slackbuilds.org>
- # This program is free software; you can redistribute it and/or modify
- # it under the terms of the GNU General Public License as published by
- # the Free Software Foundation; either version 2 of the License, or
- # (at your option) any later version, with the following exception:
- # the text of the GPL license may be omitted.
- # This program is distributed in the hope that it will be useful, but
- # without any warranty; without even the implied warranty of
- # merchantability or fitness for a particular purpose. Compiling,
- # interpreting, executing or merely reading the text of the program
- # may result in lapses of consciousness and/or very being, up to and
- # including the end of all existence and the Universe as we know it.
- # See the GNU General Public License for more details.
- # You may have received a copy of the GNU General Public License
- # along with this program (most likely, a file named COPYING). If
- # not, see <https://www.gnu.org/licenses/>.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=nodejs
- SRCNAM=node
- VERSION=${VERSION:-17.9.0}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -eu
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $SRCNAM-v$VERSION
- tar xvf $CWD/$SRCNAM-v$VERSION.tar.xz
- cd $SRCNAM-v$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- ## Fix man page path.
- sed -i 's|share/||' tools/install.py
- ## Fix libdir for 64-bit.
- sed -i "s|lib/|lib${LIBDIRSUFFIX}/|g" tools/install.py
- sed -i "s/'lib'/'lib${LIBDIRSUFFIX}'/" lib/module.js
- sed -i "s|\"lib\"|\"lib${LIBDIRSUFFIX}\"|" deps/npm/lib/npm.js
- sed -i "s|math.h|cmath|" src/node_crypto.cc
- ./configure \
- --prefix=/usr \
- --shared-zlib \
- --ninja
- make CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS"
- make install DESTDIR=$PKG
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- ## Add bash completion file for npm.
- install -D -m 644 $CWD/npm.sh $PKG/usr/share/bash-completion/completions/npm
- ## Remove unneeded files.
- find $PKG/usr \( -name '.git*' \) -exec rm -f {} \;
- ## Set NODE_PATH to look for globally installed modules.
- mkdir -p $PKG/etc/profile.d
- cat > $PKG/etc/profile.d/${SRCNAM}.csh << EOF
- #!/bin/csh
- setenv NODE_PATH /usr/lib${LIBDIRSUFFIX}/node_modules
- EOF
- cat > $PKG/etc/profile.d/${SRCNAM}.sh << EOF
- #!/bin/sh
- export NODE_PATH=/usr/lib${LIBDIRSUFFIX}/node_modules
- EOF
- chmod 0755 $PKG/etc/profile.d/*
- # Fix some files path
- mv $PKG/usr/doc/node $PKG/usr/share/nodejs
- mv $PKG/usr/systemtap $PKG/usr/share/systemtap
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a AUTHORS LICENSE *.md $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|